again: Error opening db: No backend database support….

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Nightlies Feedback again: Error opening db: No backend database support….

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #385
    t0m
    Participant

    I’ve been using mt-daapd-cvs-20051122 so far and thought it might be time to test the latest Nightlies version mt-daapd-svn-1249.

    I’ve done
    ./configure –enable-sqlite –enable-debug –enable-mdns –enable-oggvorbis –enable-flac

    just the way I did it all the versions before.

    I’ve made the needed changes to /sr/local/etc/mt-daapd.conf
    and created the directory /usr/local/var/cache/mt-daapd with the corresponding user rights.

    Still I get the error: “Error opening db: No backend database support for type: = sqlite”

    So – What’s going wrong here…

    ./mt-daapd -d9 -f -y
    setting dest to 1
    Expanding precomments to 256
    Expanding precomments to 512
    Expanding precomments to 1024
    Found 1 tokens in /mp3/
    Token 1: /mp3/
    Expanding precomments to 2048
    Checking existence of /usr/local/share/mt-daapd/admin-root
    Checking existence of /usr/local/share/mt-daapd/admin-root
    Checking existence of = /usr/local/var/cache/mt-daapd
    Creating = /usr/local/var/cache/mt-daapd
    Checking existence of /usr
    Checking existence of /usr/local
    Checking existence of /usr/local/var
    Checking existence of /usr/local/var/cache
    Checking existence of /usr/local/var/cache/mt-daapd
    Checking existence of = /usr/local/var/cache/mt-daapd
    Checking existence of /usr/local/share/mt-daapd/plugins
    Checking existence of /usr/local/share/mt-daapd/plugins
    Loading new config file.
    setting dest to 5
    Starting with debuglevel 9
    Starting rendezvous daemon
    get_ifi_info
    intf name=lo AF=2, flags=00000002
    intf name=eth0 AF=2, flags=00000002
    intf name=eth0:0 AF=2, flags=00000002
    intf name=tun0 AF=2, flags=00000002
    SetupInterfaceList
    mDNS_RegisterInterface: InterfaceID 080994B0 192.168.0.2 not represented in list; marking active and retriggering queries
    Adding 080994C0 johndoe.local. (Addr) to active record list
    Adding 0809976C 2.0.168.192.in-addr.arpa. (PTR) to active record list
    Not creating HINFO record: platform support layer provided no information
    SetupOneInterface: eth0 192.168.0.2 Registered
    SetupOneInterface: eth0 192.168.1.2 is an alias of 192.168.0.2
    mDNS_RegisterInterface: InterfaceID 080994B0 192.168.1.2 already represented in list; marking inactive for now
    Adding 08099D10 johndoe.local. (Addr) to active record list
    Adding 08099FBC 2.1.168.192.in-addr.arpa. (PTR) to active record list
    Not creating HINFO record: platform support layer provided no information
    SetupOneInterface: eth0 192.168.1.2 Registered
    select(7, 0.000976)
    Starting signal handler
    Opening database
    Error opening db: No backend database support for type: = sqlite
    Processing rendezvous message
    Stopping mDNS
    Exiting
    mDNS_Close: RR Cache was using 0 records, 0 active
    mDNS_Deregister_internal: Deleting record for johndoe.local. (Addr)
    mDNS_Deregister_internal: Deleting record for 2.0.168.192.in-addr.arpa. (PTR)
    mDNS_Deregister_internal: Deleting record for johndoe.local. (Addr)
    mDNS_Deregister_internal: Deleting record for 2.1.168.192.in-addr.arpa. (PTR)
    mDNS_Close: No deregistering records remain
    mDNS_Close: mDNSPlatformClose
    mDNS_DeregisterInterface: Another representative of InterfaceID 080994B0 exists; making it active
    mDNS_DeregisterInterface: Last representative of InterfaceID 080994B0 deregistered; marking questions etc. dormant
    mDNS_Close: done
    Finished with status 0, result 0
    Stopping signal handler
    Signal handler started
    Got shutdown signal. Notifying daap server.

    #5208
    andrews
    Guest

    You need to install sqlite first before you switch to the nightlies. mt-daapd uses sqlite2.x by default – so you can download that one. If you want to use the latest – sqlite3 – just make sure you use this line as your configure line…

    ./configure –enable-sqlite3 –with-sqlite3-includes=/usr/local/include –with-sqlite3-libs=/usr/local/lib –enable-browse –enable-query –with-id3tag=/usr/local

    That will enable the sqlite3 support.

    You then need to go to the /etc/mt-daapd.conf file and find the line that says

    db_type = sqlite

    and change it to

    db_type = sqlite3

    again – this is only if you install sqlite3. sqlite2 = db_type sqlite.

    #5209
    andrews
    Guest

    oops…

    I believe the mt-daapd.conf is in /usr/local/etc by default now

    #5210
    rpedde
    Participant

    @andrews wrote:

    oops…

    I believe the mt-daapd.conf is in /usr/local/etc by default now

    Oops… probably. I meant to take that out. It will be removed next release… it will only look in /etc (well, sysconfdir)

    As far as t0m’s problem — the config file got moved to an ini-style format… so you have stuff like:

    mp3_dir /path/to/mp3
    something_else /blah/blah/blah

    right?

    And then you added:

    db_type = sqlite

    so it’s trying to open a db type of “=sqlite”, not “sqlite”. Easiest thing to do is to convert your config file:


    mt-daapd -v -c /path/to/mt-daapd.conf

    and it should then be in .ini format, then edit the db stuff.

    — ron

    #5211
    t0m
    Participant

    @andrews wrote:

    I believe the mt-daapd.conf is in /usr/local/etc by default now

    yes – that’s where my conf is 😉

    @rpedde wrote:

    As far as t0m’s problem — the config file got moved to an ini-style format… so you have stuff like:

    mp3_dir /path/to/mp3
    something_else /blah/blah/blah

    right?

    And then you added:

    db_type = sqlite

    so it’s trying to open a db type of “=sqlite”, not “sqlite”.

    exactly .. that’s been the error…

    Easiest thing to do is to convert your config file:


    mt-daapd -v -c /path/to/mt-daapd.conf

    and it should then be in .ini format, then edit the db stuff.

    that gave me the error:


    setting dest to 4
    Converting config file...
    Error writing config file.

    but the file was converted right.

    thanks for you help

    /t0m

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘Nightlies Feedback’ is closed to new topics and replies.