Accessing a remote Firefly from a Soundbridge using Avahi

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues Accessing a remote Firefly from a Soundbridge using Avahi

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #2589
    Anonymous
    Inactive

    Hi there,

    I’m trying to access a remote Firefly server with my Soundbridge. As a first try I set up a Rendezvous Proxy on my Windows box and everything worked find. Since I’m running a Linux based routed which is online all the time, I tried to configure Avahi to advertise the remote Firefly. Unfortunately I didn’t manage to get this setup working. I dropped the following service description into Avahi’s service directory:


    Firefly on %h


    _daap._tcp
    3689
    local
    some.remote.machine
    Machine Name = Firefly on some.remote.machine



    _rsp._tcp.
    3689
    local
    some.remote.machine
    Machine Name = Firefly on some.remote.machine


    Avahi seems to advertise the service and I could successfully access the remote Firefly with iTunes. But although the Firefly is accessible via iTunes, it does not show up on my Soundbridge. Any suggestion? Thanks in advance.

    — Wolfgang

    #17561
    fizze
    Participant

    How is everything connected? Wired, wireless?
    What kind of network equipment do you use? Brand, model?

    #17562
    Anonymous
    Inactive

    The Soundbridge is connected via WiFi. The Avahi is running on an Ubuntu 8.04. The Linux box is connected wired. Connection to the internet is through a Telekom Speedport W701V Router.

    As mentioned above: The same scenario worked using the Rendezvous Proxy running under Windows.

    #17563
    fizze
    Participant

    Ah, I blatantly overread the word “remote” 😉

    Well, Rendezvous proxy is pretty much the only thing I know of that works with remote firefly’s.

    You could achieve the same thing when using ssh, or openvpn to connect to the remote lib and using avahi, IMHO.
    IIRC someone has achieved this and posted about this here on the forums. (If it wasn’t even Ron himself)

    #17564
    Anonymous
    Inactive

    Hmmh – I read some postings where people managed to get a setup like this running using the howl-mdns-proxy. Other guys suggested using Avahi instead of howl.

    And as far as I know Firefly itself uses a linked in Avahi to advertise its service unless you specify the -m option. So I’m wondering why my setup doesn’t work with Avahi.

    #17565
    fizze
    Participant

    How is the remote firefly connected? ssh tunnel?
    You need to figure out wether the multicast packets arrive at your “proxy”, and how the forwarding works. If all multicast packets are forwarded properly, you need to find out that the same goes for the requests. Tcpdump is your ally 😉

    #17566
    Anonymous
    Inactive

    The remote firefly is accessed via internet (daap or rsp). The Avahi is running on the local side and advertises the service with its remote address. I don’t see any reason for the multicast to be transmitted to the remote side, since the advertisement takes place on the local end. Besides that – in case of general communication problems the Rendezvous Proxy setup would not have worked either. Same is true for accessing the remote server with iTunes.

    #17567
    fizze
    Participant

    Hm, “via Internet” doesn’t really cut it for me here. Do you mean its publicly available? 🙄

    I think that’s why the avahi implementation might fail, because in the cases I’ve heard of, VPN or SSH tunnels were used.

    Besides, having a daap share publicly on the internet is definetly not advised. But then, it’s not my cup of tea.

    #17568
    Anonymous
    Inactive

    You got it – I try to talk daap or rsp over the internet without any tunnel or VPN. The firefly accepts connections on a publicly available IP.

    I think the problem is more a Soundbridge issue than a firefly issue. I wonder whether there is something missing in the Avahi configuration, so that the Soundbridge also shows the share. Since the share is accessible via iTunes the overall setup seems to be ok.

    And I agree – from a security perspective this is not the optimal solution, even if the server is password protected.

    #17569
    fizze
    Participant

    The Soundbridges definetly only allow you to browse local shares – that is shares within the same network. If you do run over an IP tunnel then that does that for you.

    Setting up openVPN or even a simply tunnel with scp / putty isn’t hard. You should definetly check it out.

    #17570
    Anonymous
    Inactive

    I agree with you in that it’s not a big deal to setup a tunnel or an OpenVPN connection. But since I was successful in connecting the Soundbridge to a remote Firefly with only using the Rendezvous Proxy (no tunnel, no VPN), the Soundbridge must definitely be capable of browsing remote shares. So Im still wondering what the difference between using the Rendezvous Proxy and using Avahi is.

    #17571
    EVILRipper
    Participant

    I though RendezvousProxy actually creates a tunnel.
    I used to use it too — Rendezvousproxy at school, to point local 3689 to remote port 3689 on my server, so iTunes saw a ‘local’ music share at school.

    #17572
    Anonymous
    Inactive

    I though RendezvousProxy actually creates a tunnel.

    No – Rendezvous Proxy as well as Avahi only advertises address and port of (possibly remote) service to consumers in the local network. No tunnel will be established – neither by Rendezvous Proxy nor by Avahi. The connection to the remote end is actually being established by the local device.

    #17573
    Anonymous
    Inactive

    This post is pretty nice!
    I’d support you 100%!!!

    #17574
    Anonymous
    Inactive

    Finally I managed to access my remote server! Here is what I configured to make it work:

    First I created the service configuration (/etc/avahi/services/firefly.service) which is pretty similar to what I published in my first post. Basically the only, but important difference is that I did not specify the official host name of the remote server. Instead I used a host name which is in the .local domain.


    Firefly on musicbox


    _daap._tcp
    3689
    local
    musicbox.local



    _rsp._tcp
    3689
    local
    musicbox.local



    Since the musicbox.local host name has to be resolved to the server’s official IP address, I added a static host to /etc/avahi/hosts:

    11.22.33.44 musicbox.local

    That’s all! Now both of my Soundbridges (A Roku and a Pinnacle) are able to connect to the remote Firefly.

Viewing 15 posts - 1 through 15 (of 15 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.