You are here: Home » Topic » 20060319 and Soundbridge works better

20060319 and Soundbridge works better

This topic contains 7 replies, has 2 voices, and was last updated by  rpedde 11 years, 7 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #208

    tri
    Participant

    Hi

    I had time to only take a glimpse, so I can’t really tell. However,
    20060319 seems to work with Roku. At least I was able to browse
    artists and (smart) playlists, start (ssc) streaming, and use the web
    interface.

    I’ll leave the streaming on and report back possible anomalies later.

    –tri

    #4121

    tri
    Participant

    It had crashed after some time. I’ll restart it with
    higher debug level.

    Roku was streaming and web browser was showing the status
    space. Maybe threads still get stuck somehow. Streaming
    was OK until the crash.

    This is syslog excerpt:
    Mar 20 08:19:27 rinne mt-daapd[4057]: Starting web server from /usr/local/share/
    mt-daapd/admin-root on port 3689
    Mar 20 08:19:27 rinne mt-daapd[4057]: Registering rendezvous names
    Mar 20 08:19:27 rinne mt-daapd[4057]: Scanned 22976 songs in 20 seconds
    Mar 20 09:23:47 rinne mt-daapd[4062]: Could not spawn thread: Resource temporarily unavailable
    Mar 20 09:23:47 rinne mt-daapd[4062]: Fatal error… Aborting
    Mar 20 09:23:47 rinne mt-daapd[4056]: Rendezvous socket closed (daap server crashed?) Aborting.
    Mar 20 09:23:47 rinne mt-daapd[4056]: Fatal error… Aborting

    –tri

    #4122

    rpedde
    Participant

    could not spawn thread sounds particularly bad. ssc children not getting reaped? process table full?

    grumble…

    #4123

    tri
    Participant

    rpedde wrote:

    could not spawn thread sounds particularly bad. ssc children not getting reaped? process table full?

    Surprisingly not. There are no extra threads and the ‘killing factor’
    evidently was the web page constantly realoading the page. My Roku
    has now streamed for 24 hours straight through ssc but now without
    web status page polling all the time.

    –tri

    #4124

    SurferMC

    jgatts wrote:

    Using a Roku Soundbridge M1000 with 2.3.44 software, I can stream without problems. However, if I exit to select another shared library, and then try to connect to mt-daapd again, I get “Connection to Server Failed.” This is because mt-daapd has crashed.

    I get the same problem but with a different version of Soundbridge software 2.5.133.

    #4125

    rpedde
    Participant

    Fix is in svn. I’ll drop a nightly tomorrow, assuming I’m not dead from whatever it is I came down with yesterday.

    Ugh.

    — Ron

    #4126

    tri
    Participant

    rpedde wrote:

    I’ll drop a nightly tomorrow, assuming I’m not dead from whatever it is I came down with yesterday.

    If it’s anything like the flu I got a couple of days ago, don’t count on it 😉

    –tri

    #4127

    rpedde
    Participant

    Good call. I didn’t even get out of be until 6:00 pm. And I’m about to head back to bed now. I feel like death warmed over.

    — Ron

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.