You are here: Home » Topic » 1534 Build Problem with Ubuntu 6.10

1534 Build Problem with Ubuntu 6.10

This topic contains 3 replies, has 2 voices, and was last updated by  rpedde 10 years, 4 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1286

    atmurray
    Participant

    Hi, I’m trying to do a build of the latest nightly (I want to make a little patch to the source code) and am running into trouble. I’m basically doing a standard mkdist.sh build except without sqlite3. This is all running on Ubuntu Server 6.10. I’ve turned on verbose for automake and this is what I get after make enters the src directory:

    make[1]: Entering directory `/home/alanm/mt-daapd/src’
    here=`cd .. && pwd`;
    top_distdir=`cd ../mt-daapd-svn-1534 && pwd`;
    distdir=`cd ../mt-daapd-svn-1534/src && pwd`;
    cd ..
    && automake-1.4 –include-deps –build-dir=$here –srcdir-name=.. –output-dir=$top_distdir –gnu src/Makefile
    automake: reading configure.in
    automake: reading aclocal.m4
    automake: reading src/Makefile.am
    src/Makefile.am:3: SUBDIRS defined both conditionally and unconditionally
    src/Makefile.am:8: LDADD defined both conditionally and unconditionally
    automake: creating src/Makefile.in
    make[1]: *** [distdir] Error 1
    make[1]: Leaving directory `/home/alanm/mt-daapd/src’
    make: *** [distdir] Error 1

    As you can see it’s fairly cryptic but I’d presume it has something to do with creating Makefile.in?

    The only other warnings I get are when autoconf runs from reconf.sh:

    config.status: creating src/Makefile
    config.status: WARNING: src/Makefile.in seems to ignore the –datarootdir setting
    config.status: creating src/plugins/Makefile
    config.status: WARNING: src/plugins/Makefile.in seems to ignore the –datarootdir setting
    config.status: creating admin-root/Makefile
    config.status: WARNING: admin-root/Makefile.in seems to ignore the –datarootdir setting
    config.status: creating admin-root/lib-js/Makefile
    config.status: WARNING: admin-root/lib-js/Makefile.in seems to ignore the –datarootdir setting
    config.status: creating admin-root/lib-js/script.aculo.us/Makefile
    config.status: WARNING: admin-root/lib-js/script.aculo.us/Makefile.in seems to ignore the –datarootdir setting
    config.status: creating contrib/Makefile
    config.status: WARNING: contrib/Makefile.in seems to ignore the –datarootdir setting
    config.status: creating contrib/init.d/Makefile
    config.status: WARNING: contrib/init.d/Makefile.in seems to ignore the –datarootdir setting
    config.status: creating src/mdns/Makefile
    config.status: WARNING: src/mdns/Makefile.in seems to ignore the –datarootdir setting
    config.status: creating Makefile
    config.status: WARNING: Makefile.in seems to ignore the –datarootdir setting

    Any help would be appreciated, if more info is needed just let me know.

    #10095

    rpedde
    Participant

    @atmurray wrote:

    Hi, I’m trying to do a build of the latest nightly (I want to make a little patch to the source code) and am running into trouble. I’m basically doing a standard mkdist.sh build except without sqlite3. This is all running on Ubuntu Server 6.10. I’ve turned on verbose for automake and this is what I get after make enters the src directory:

    If you aren’t making a patch that requires configure.in changes, then just do it from a nightly. Since the change to mdns, I’ve managed to add some configure crap that doesn’t work except on the version of autotools I have, obviously.

    I’ll try and get it worked out soon, but until then, just patch a nightly, since that already has a configure.

    — Ron

    #10096

    atmurray
    Participant

    Ahh now I get it, sorry my question seems rather still now.

    Cheers.

    #10097

    rpedde
    Participant

    @atmurray wrote:

    Ahh now I get it, sorry my question seems rather still now.

    Cheers.

    np. I’ll try to get the configure junk worked out soon so everyone can work from svn, though.

    — Ron

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.