You are here: Home » Topic » 1450 – aborting

1450 – aborting

This topic contains 6 replies, has 3 voices, and was last updated by  rpedde 10 years, 8 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #863

    MCFH
    Participant

    Ron,
    I have 1450 installed and now frequently have the firefly server crash:


    2006-12-04 22:40:41 (d47a441f): Skipping file, not modified
    2006-12-04 22:40:41 (d47a441f): Found C:Documents and SettingsiTunes.CARILLONINVESTMMy DocumentsMy MusiciTunesiTunes MusicCompilationsBest of Johnny Cash/03 Sunday Morning Coming Down.m4a
    2006-12-04 22:40:41 (d47a441f): Executing: select * from songs where path='C:Documents and SettingsiTunes.CARILLONINVESTMMy DocumentsMy MusiciTunesiTunes MusicCompilationsBest of Johnny Cash3 Sunday Morning Coming Down.m4a' and idx=0
    2006-12-04 22:40:41 (d47a441f): Executing: INSERT INTO updated VALUES (142)
    2006-12-04 22:40:41 (d47a441f): Query: INSERT INTO updated VALUES (142)
    2006-12-04 22:40:41 (d47a441f): Error: unable to open database file
    2006-12-04 22:40:41: Aborting

    This is either due to McAfee Total Protection slowing down the response times or something in your app.
    Either way it seems to run for 10-15 mins and then this happens.
    Regards
    Mark

    #7715

    fizze
    Participant

    well, “unable to open DB” speaks a different language.
    either your McAffee blocks access, or something else is wrong with the rig.

    you can connect fine and see all content for 10-15 minutes though?

    #7716

    MCFH
    Participant

    Yes – all fine until it does a rescan. It never stops on the same song though either…

    #7717

    rpedde
    Participant

    @fizze wrote:

    well, “unable to open DB” speaks a different language.
    either your McAffee blocks access, or something else is wrong with the rig.

    you can connect fine and see all content for 10-15 minutes though?

    It’s McAfee. SQLite does transactions by opening the database in exclusive write, and closing the database when the transaction is done. McAfee in its realtime scanning “feature” blocks access to the file while it scans it *for every sqlite transaction*.

    Furthermore, McAfee doesn’t have a way to exclude a file from scanning. Strangely, I don’t hear this from any users except McAfee. I would have thought I’d have heard it from Norton or Kaspersky or whoever else, but there must be something a little different that McAfee does that the other guys don’t. Not sure what.

    I did notice that the release notes for sqlite 3.3.6 says: “Changes include improved tolerance for windows virus scanners”. I was going to tr a 3.3.8 version and see what it did.

    But you can test this yourself… download the sqlite 3.3.8 dll here:

    http://www.sqlite.org/sqlitedll-3_3_8.zip

      * Stop the firefly server
      * Copy the .dll file from the zip file into your c:program filesfirefly media server.
      * Start the server, go into the web config page by using the pushbutton on the tray applet to open the config page.
      * Go to the “config” tab on the web interface
      * Set the display to advanced
      * Change the “db type” to sqlite3.
      * Stop the server
      * Start the server
      * Wait for the scan to finish

    I’d be interested to hear if it helped.

    — Ron

    #7718

    MCFH
    Participant

    Thanks Ron,
    I had disabled McAfee last night and the problem went away – I will report back on the latest sqllite3 in a few days.
    Mark

    #7719

    MCFH
    Participant

    All sorted with the sqllite3 you linked through to…
    Thanks again
    Mark

    #7720

    rpedde
    Participant

    @mcfh wrote:

    All sorted with the sqllite3 you linked through to…
    Thanks again
    Mark

    Interesting. Guess I’ll have to bundle that version with the nightlies.

    — Ron

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.