You are here: Home » Topic » 1281 Build issues – Ubuntu

1281 Build issues – Ubuntu

This topic contains 3 replies, has 2 voices, and was last updated by  rpedde 11 years, 3 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #424

    n8gray
    Participant

    Hi folks,

    I’m trying to build svn 1281 on Ubuntu Dapper Drake. I’m having problems when ffmpeg is enabled:


    [email protected]:~/Downloads/mt-daapd-svn-1281$ ./configure --enable-sqlite --enable-ffmpeg --with-ffmpeg-includes=/usr/include/ffmpeg
    . . .
    [email protected]:~/Downloads/mt-daapd-svn-1281$ make
    . . .
    if /bin/sh ../../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../.. -g -Wall -DHAVE_SQL -DHOST='"i686-pc-linux-gnu"' -DNOT_HAVE_SA_LEN -I/usr/include/ffmpeg -I.. -g -O2 -MT compat.lo -MD -MP -MF ".deps/compat.Tpo" -c -o compat.lo compat.c;
    then mv -f ".deps/compat.Tpo" ".deps/compat.Plo"; else rm -f ".deps/compat.Tpo"; exit 1; fi
    mkdir .libs
    gcc -DHAVE_CONFIG_H -I. -I. -I../.. -g -Wall -DHAVE_SQL -DHOST="i686-pc-linux-gnu" -DNOT_HAVE_SA_LEN -I/usr/include/ffmpeg -I.. -g -O2 -MT compat.lo -MD -MP -MF .deps/compat.Tpo -c compat.c -fPIC -DPIC -o .libs/compat.o
    compat.c:402: error: syntax error before '__extension__'
    compat.c:402: error: syntax error before '&&' token
    compat.c:405: error: syntax error before '&&' token
    make[3]: *** [compat.lo] Error 1

    The compat.c file doesn’t have anything like ‘__extension__’ or ‘&&’ at line 402.

    The problem goes away if I don’t enable ffmpeg support. Any suggestions?? 😕

    #5478

    rpedde
    Participant

    @n8gray wrote:

    Hi folks,

    I’m trying to build svn 1281 on Ubuntu Dapper Drake. I’m having problems when ffmpeg is enabled:


    [email protected]:~/Downloads/mt-daapd-svn-1281$ ./configure --enable-sqlite --enable-ffmpeg --with-ffmpeg-includes=/usr/include/ffmpeg
    . . .
    [email protected]:~/Downloads/mt-daapd-svn-1281$ make
    . . .
    if /bin/sh ../../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../.. -g -Wall -DHAVE_SQL -DHOST='"i686-pc-linux-gnu"' -DNOT_HAVE_SA_LEN -I/usr/include/ffmpeg -I.. -g -O2 -MT compat.lo -MD -MP -MF ".deps/compat.Tpo" -c -o compat.lo compat.c;
    then mv -f ".deps/compat.Tpo" ".deps/compat.Plo"; else rm -f ".deps/compat.Tpo"; exit 1; fi
    mkdir .libs
    gcc -DHAVE_CONFIG_H -I. -I. -I../.. -g -Wall -DHAVE_SQL -DHOST="i686-pc-linux-gnu" -DNOT_HAVE_SA_LEN -I/usr/include/ffmpeg -I.. -g -O2 -MT compat.lo -MD -MP -MF .deps/compat.Tpo -c compat.c -fPIC -DPIC -o .libs/compat.o
    compat.c:402: error: syntax error before '__extension__'
    compat.c:402: error: syntax error before '&&' token
    compat.c:405: error: syntax error before '&&' token
    make[3]: *** [compat.lo] Error 1

    The compat.c file doesn’t have anything like ‘__extension__’ or ‘&&’ at line 402.

    The problem goes away if I don’t enable ffmpeg support. Any suggestions?? 😕

    What version of ffmpeg?

    Acutally, after thinking about it, it sounds like it has detected that you dont’ have strsep and has set it to be some kind of macro.

    You could change line 402 in compat.c from:


    #if !HAVE_STRSEP

    to


    #if !HAVE_STRSEP && !strsep

    — Ron

    #5479

    joeyo

    Hi,

    I have the exact same issue reported above with Debian Etch and svn-1333. If I configure without ffmpeg, I get:

    checking for strsep... yes

    otherwise,

    checking for strsep... no

    Weird, eh?

    Changing line 401 in compat.c to

    #if !HAVE_STRSEP && !strsep

    as suggested above does not fix the issue.

    I have libavcodec-dev from: http://packages.debian.org/testing/libdevel/libavcodec-dev

    I am configuring as follows:

    ./configure --enable-sqlite --enable-ffmpeg --with-ffmpeg-includes=/usr/include/ffmpeg

    Thanks,

    #5480

    rpedde
    Participant

    I have an etch box at work. I can give it a try there.

    — Ron

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.