You are here: Home » Topic » 0.2.1.1 not iTunes 5 compatible – Patch Available!

0.2.1.1 not iTunes 5 compatible – Patch Available!

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server General Discussion 0.2.1.1 not iTunes 5 compatible – Patch Available!

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #94
    Anonymous
    Guest

    I guess Apple changed the protocol because when I try to connect to my mt-daapd share I get the message “The shared music library is not compatible with this version of iTunes.” Can anyone figure out a work around or know when an update will be available?

    Post edited by: rpedde, at: 2005/09/08 02:50

    #3592
    [APi]TheMan
    Guest

    Yeah, here I came all gung ho to work and stoked to download iTunes 5. I fire up RendezvousProxy to get my mt-daapd, and NO! Not compatable. Sad day for us music sharers.

    #3593
    uthanda
    Participant

    I can confirm that iTunes 5.0 works with 4.9. I’ve also grabbed network traces of the DAAP response from both mt-daapd and iTunes 5.0. I haven’t had time to review it, but if an mt-daapd hacker want to review it, just let me know. I can post them somewhere if need be. Just tell me where.

    #3594
    uthanda
    Participant

    I can also confirm that the latest nightly is working fine with iTunes 5.0. Guess it’s time to update my server. Thanks again Ron et al for this awesome work.

    #3595
    uthanda
    Participant

    Let me ask the dumb question. Did you restart the mt-daapd server and/or start the correct binary?

    #3596
    rpedde
    Participant

    Oy!

    I forgot about the thing today! Guess that’ll teach me!

    I’m installing everything now. I’ll be back once I figure out what’s up.

    — Ron

    #3597
    uthanda
    Participant

    Just go to the nightlies link to the left. Download the first one there. (or at least I assume as I used Lynx to get it the first time). I did have an issue on my Slackware 9.1 box with Bonjour not working right. Had to install Howl instead, though that works.

    #3598
    rpedde
    Participant

    Enclosed please find patch for 0.2.1.1 to fix iTunes 5 compatibility.

    Sorry it took me so long, I completely forgot about the announcement today! I’ll probably make a 0.2.1.2 release to fix this. It won’t be until tomorrow, though, as I don’t have any i386 debian boxes set up. Or redhat.

    Grr… I just yesterday found the power plug for my slug.

    Moving sucks.

    — Ron

    [file name=daap.c.patch.txt size=1543]http://www.mt-daapd.org/components/com_simpleboard/uploaded/files/daap.c.patch.txt[/file]

    #3599
    uthanda
    Participant

    Not sure on that one. I only use Linux / Solaris. Wish I could help.

    #3600
    rpedde
    Participant

    There are nightly builds for nslu2 on the nightlies tab. As soon as I find my debian box, I’ll build updated nslu2 and debian packages based on the 0.2.1.1 codebase.

    — Ron

    #3601
    rpedde
    Participant

    I’m in #mt-daapd on FreeNode right now, if anyone is bored and wants to bug me in real-time about getting those packages faster. 🙂

    — ROn

    #3602
    rpedde
    Participant

    updated tarballs, “sarge” packages and nslu2 packages are on the nightlies site (see the link to the left).

    If you use them, PLEASE state platform and version and success or failure.

    So far all I have tested is:

    Debian “sarge” amd64 – tarball – success
    Debian “sarge” x86 – debian package – success
    Mac OSX 10.4.2 – tarball – success

    I need feedback on Solaris, *bsd, and nslu2.

    — Ron

Viewing 12 posts - 1 through 12 (of 12 total)
  • The forum ‘General Discussion’ is closed to new topics and replies.