You are here: Home » Reply

Reply To: Linux: Error staring web server: Address already in use

#9971

[email protected]
Participant

Thank you for your respond,

there was no service with that port defined in my /etc/services .. i knew there had to be something blocking that port, tho i had no idea how to find it – but then when logging in from my mac it suddenly worked. Stupid me!, i was accessing the linux machine with the firefly service from a windows ssh client which accidentally had a remote tunnel instead of a local one defined on port 3689 *duh*! So it was the sshd server which grabbed that port. Human failure, problem solved.

What is still not working is the access thru the ssh tunnel (not a remote one this time 😉 with rendevous-proxy – iTunes shows the daapd in the list but as soon as i click on it it, it tries to get the data but after a few seconds it would jump back to the local music … but as i read in other posts it’s not that easy to tunnel it .. accessing the web gui works flawlessly with the tunnel up and opening http://localhost:3689, the rendevous proxy announces the service to iTunes as it shows up in the shared music list. When i cut the tunnel and leave the proxy running, the share still shows up in iTunes but as soon as i click on it it says Error -3260, which is correct then. So the problem seems to reside on either the ssh client or server side i guess.

Update:

I just tried the tunnel connectin with just 10 files in the mp3 directory and that would work. So it seems that there is some kind of a limit? My “real” library has about 8.200 songs – maybe too much for such a tunnel?