You are here: Home » Reply

Reply To: Broken support for Russian song names

#9480

rpedde
Participant

@gva0002 wrote:

It appears that after moving to Vista (32) songs with Russian or French characters in the filename/tag do not play anymore. While browsing for artist/album non-English characters display correctly. Firefly version 1498 and the most recent beta firware on Roku (2.7b11). Any suggestions?

Firefly log:
+++++++++++++++++++++++++
2007-03-06 19:28:48 (b807f2b2): Firefly Version svn-1498: Starting with debuglevel 2
2007-03-06 19:28:48 (b807f2b2): Starting rendezvous daemon
2007-03-06 19:28:48 (b807f2b2): Building drive mapping table from C:Program FilesFirefly Media Servermapping.ini
2007-03-06 19:28:48 (b807f2b2): Old database version: 12, expecting 13
2007-03-06 19:28:48 (b807f2b2): Upgrading db: 12 –> 13
2007-03-06 19:28:50 (b807f2b2): Initializing database
2007-03-06 19:28:51 (b807f2b2): Starting web server from C:Program FilesFirefly Media Serveradmin-root on port 9999
2007-03-06 19:28:51 (b807f2b2): Registering rendezvous names
2007-03-06 19:28:51 (b807f2b2): Serving 1680 songs. Startup complete in 3 seconds
2007-03-06 19:28:51 (b807f2b2): Rescanning database
2007-03-06 19:29:03 (b807f2b2): Starting playlist scan
2007-03-06 19:29:03 (b807f2b2): Updating playlists
2007-03-06 19:29:03 (b807f2b2): Scanned 1680 songs (was 1680) in 12 seconds
2007-03-06 19:29:15 (194663b5): Thread 0: Entering ws_returnerror (302: Moved)
2007-03-06 19:29:44 (605e6e70): Session 0: Streaming file ’01 – ??????????????????.wma’ to 192.168.2.2 (offset 0)
2007-03-06 19:30:06 (c70d6041): Session 0: Streaming file ’01 – ?? ?????????????????? ????????????????.wma’ to 192.168.2.2 (offset 0)
2007-03-06 19:30:44 (19504287): Session 0: Streaming file ’01 – ??????????.wma’ to 192.168.2.2 (offset 0)
2007-03-06 19:39:05 (b807f2b2): Rescanning database
2007-03-06 19:39:16 (b807f2b2): Starting playlist scan
2007-03-06 19:39:16 (b807f2b2): Updating playlists
2007-03-06 19:39:16 (b807f2b2): Scanned 1680 songs (was 1680) in 11 seconds
2007-03-06 19:49:18 (b807f2b2): Rescanning database
2007-03-06 19:49:29 (b807f2b2): Starting playlist scan
2007-03-06 19:49:29 (b807f2b2): Updating playlists
2007-03-06 19:49:29 (b807f2b2): Scanned 1680 songs (was 1680) in 11 seconds
2007-03-06 19:59:32 (b807f2b2): Rescanning database
2007-03-06 19:59:42 (b807f2b2): Starting playlist scan
2007-03-06 19:59:42 (b807f2b2): Updating playlists
2007-03-06 19:59:43 (b807f2b2): Scanned 1680 songs (was 1680) in 11 seconds
2007-03-06 20:03:02 (7ffd02d4): Session 0: Streaming file ’01 – ?????????????????????????????? ????????.wma’ to 192.168.2.2 (offset 0)
2007-03-06 20:09:45 (b807f2b2): Rescanning database
2007-03-06 20:09:57 (b807f2b2): Starting playlist scan
2007-03-06 20:09:58 (b807f2b2): Updating playlists
2007-03-06 20:09:58 (b807f2b2): Scanned 1680 songs (was 1680) in 13 seconds

So they display alright in iTunes or on the soundbridge, just don’t stream? Is that correct?

And the same build worked on XP, is that right?