You are here: Home » Reply

Reply To: mt-daapd not working after power out – Debian Etch on NSLU2

#9363

rpedde
Participant

@wabe wrote:

Thanks for the tip! I’ve already changed the domain to *.int* instead of .local but still receive the error-message. Reluctant to change back to .local considering the “best-practice” advice not to use it.
I’m puzzled about these problems since everything worked fine until power went out. I wonder if this .local behavior of Avahi is a “new feature” that started off by me running “apt-get upgrade”?
I’ve noticed that mt-daapd is running (ps -Al | mt-daapd shows 3 instances) but pretty useless since it cannot communicate with the outside world.
Do you know of any forum specificaly aimed at Avahi issues or have any other suggestions on how to proceed?

I’d guess the etch startup script is checking for a local unicast zone. You might be able to edit /etc/init.d/avahi (or mDNSresponder, whatever the startup script is called) and disable the check for the unicast zone.