You are here: Home » Reply

Reply To: Pinnacle Soundbridge – MSS installation problems

#8982

rojbalc
Participant

Thanks for the help Ron, even though you appear to have posted as me just to confuse…(!)

@rojbalc wrote:

Probably isn’t a valid directory. I’m assuming you made a new share called “Admin1” and that the music sits in a directory under that share called “My Music”, right? If so, the path is probably:

/shares/mss-hdd/Admin1/My Music

But I’m not sure. You might telnet into the box and explore with “ls” and “cd” to see if you can find the right path. I’d guess it’s the one above, though.

Exactly. Schoolboy error!

Anyway, I’m up and running now – unbelievably I actually managed to sort the main problem out myself in the end too:

As I mentioned, the Server had been up and running, but then it suddenly disappeared again and I didn’t know why. I assumed this was to do with the rendezvous.conf file – that it was no longer advertising mt-daapd to my Soundbridge. Given that I had re-entered the last 4 lines of the file from memory and previously had no experience with Linux, it was likely I’d got it wrong… After playing around with this for a while I realised this wasn’t the case – no matter what I did, the MSS wasn’t visible.

Next I tried to start the process manually with


# /opt/sbin/mt-daapd -c /opt/etc/mt-daapd/mt-daapd.conf

This worked – the Server was visible again. It just wasn’t starting automatically. I thought the “/opt/lib/ld.so.1” part of the S60mt-daapd file wasn’t working properly and that my libraries weren’t up to date or something. Unlikely though, as they’d downloaded without any problems.

Eventually I found a thread where someone had posted the entire contents of the S60mt-daapd file and by comparing the 2, it turned out that in mine, the line “export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/lib” had been justified during text editing so it was directly behind the line “# can be removed”, so the line read


# can be removed export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/lib

and the library wasn’t be exported/loaded properly… Aaarrggghh! I knew the text editing would be my downfall!

Anyway, after remedying that, everything was fine and the processes started automatically. Result!

3 minor things to sort out still (ok, 2 minor and 1 major pain in the @rse that is Zonealarm):

1. The Twonky stuff. (It wasn’t me who originally installed it – I bought my MSS second hand). The processes were still running on the MSS and being displayed on my Soundbridge. In the end I took the rather rudimentary step of simply deleting the server file. This meant that it was no longer displayed on my Soundbridge, but I don’t think the MSS was very happy about it and was whirring and clicking (to use the technical jargon) rather a lot after a reboot and took ages to come online again. Thanks for the tip though – I’ll have a look on the Twonky forums to see about deleting the rest.

2. The MSS does not like shutting down while mt-daapd is running. The usual tap of the on/off button and it took between 30-60 seconds to shut down as opposed to the usual 5-10. Simply leaving the MSS on would be the simple solution, but I did plan to turn it off at night… I could always shut the server down via the web GUI, but that kind of defeats the object of a pc-independent NAS solution… I’ll have another go tonight and see if it improves. I’ve heard of such problems with the Slug, but not on MSS. Anyone had a similar experience?

3. New firewall software – I HATE ZONEALARM!! It doesn’t even let me see the MSS as a drive on my pc unless I restart the firewall. Not a great solution for an always-on internet connection… Anyone have any (software) suggestions/recommendations?

Other than that – very happy! (Donation to the Soundforge cause has already been made…)

Now to start looking for a new sibling for my Soundbridge…

Thanks again,
roj.