You are here: Home » Reply

Reply To: Build firefly nightly on WL-500g

#8840

wouter
Participant

@rootgar wrote:

i have tried to get the “mipsel” nightly (mt-daapd_svn-1498-1_mipsel.ipk) run on my asus wl-hdd (which is running the “same” FW like the 500g).
but i get following error, when starting the S60xxxx script:
/opt/etc/init.d/S60mt-daapd: /opt/etc/init.d/S60mt-daapd: 13: opt/sbin/mt-daapd: not found

but the file is there and has the status x, so it should be executeable.

The nightlies built by Ron don’t work, it’s built for NSLU2, your router uses OptWare.

@rootgar wrote:

i tried just the .ipk from wouter -> the same…

That’s strange. You might want to check dependencies like Ron suggested. I suspect a dependency version issue. I built the package against the versions currently in the wl500g feed repository, you might want to try an ipkg update, this should update to the right versions. Also make sure you have sqlite (version 2, not 3!), libid3tag and gdbm installed. I’m not completely sure my package is built properly to automatically install these (haven’t tested that). Does your router have everything installed in the usual locations (/opt/sbin, /opt/bin and /opt/lib)?

@rootgar wrote:

when installing the ipk (both) i got the error message from chown that the user “guest” no exists. (chown: unknown user name: guest)
thats correct(?), on the olegs firmware it calls “nobody”(?)

That’s ‘normal’ in the sense that I also got this. There is no ‘guest user’ on my router either. I did a ‘ipkg install adduser’ (or useradd, don’t remember exactly), added a guest user and installed the package again (remember to remove it first). Also, I start the server as root anyway by changing the mt-daapd.conf