You are here: Home » Reply

Reply To: Promblem Playing FLAC files

#8628

rpedde
Participant

@bkaatz wrote:

I’ve added the extension .flac to the list of extensions listed in the online FF configuration and added a the music folder containing all my .flac files (and just a few .mp3 files). SB sees the .flac files, displays the song names with a little “x” in front of each file name, and will not play them.

Do I need a plug-in or to change additional configuration settings? I’m thinkin the problem is with transcoding. After consulting the wiki, I changed the adv. config. of the SSC Program to: ssc_prog /usr/local/sbin/mt-daapd-ssc.pl and then the SSC Codec Types to: ssc_codectypes flac,shn,ogg,alac. Still didn’t work after the complete re-scan (even delected the songs.db file first).

Additionally, is there an app that will help me organize my .flac files so they will be browsable in SB by ARTIST and ALBUM without changing the file names of the .flac files?

You need two things… to pick up the metadata (which will give you the artist and album info in the db), you need to configure with “–enable-flac”, and have the flac libs and whatnot installed (via fink or darwinports, probably).

As far as transcoding, you may have better luck with mt-daapd-ssh.sh. You’ll need to edit it and put in the full paths to the files up at the top… like instead of:


FLAC=flac

you’ll need to do something like:


FLAC=/sw/bin/flac

For example. You’ll want to change all the other files up at the top the same way — flac, alac, oggdec, and wavstreamer (probably in /usr/local/bin, based on your example above).

— Ron