You are here: Home » Reply

Reply To: I think I have it setup correctly, but…

#8623

rpedde
Participant

@bbjonz wrote:

Thanks. I tried several different versions of installing with dpkg but none work with –enable-avahi. Could I trouble you for the complete installation statement?

BTW, that’s 10.4.8–don’t know that face got there…

Joe

I don’t have binary packages for avahi and dapper. The packages that are installed with binaries are with the built-in mdns.

But we can still probably make it work.

one thing to check is that you didn’t upgrade from a 0.2.4 install to the nightlies. If so, you’ll need to fix your config file to make it pick up the output plugins.

If your /etc/mt-daapd.conf looks like this:


servername blah
mp3_dir /path/to/somewhere

Then you have the old config style. You should be able to convert that by doing this (as root):


mt-daapd -v /etc/mt-daapd.conf

That will convert your config from the old form to the new form. It will look something like this, then:


[general]
servername=blah
mp3_dir=/path/to/blah

Once it’s in a good form, then you can add a section that looks like this:


[plugins]
plugin_dir = /usr/share/mt-daapd/plugins

Or wherever your plugins are. Check that directory, and look for an “out-daap.so” or a “rsp.so”. Just throw that whole section label and parameter at the bottom of the file (unless it already exists there).

Then start the server. That’s one of the possible problems is that it isn’t loading the plugins, so it doesn’t bother advertising anything, since you don’t have a daap server or a rsp server running, so no point in advertising anything. :-/

If that doesn’t go, or if everything was already set up okay, then the problem must be the mdns stepping on each other.

You can change the startup script for mt-daapd to start with a “-m”, which turns off multcast. Then you can edit the avahi config file to advertise “_daap._tcp” on port 3689, and “_rsp._tcp” on port 3689 as well.

Then you should be able to see it.

I’m not sure how to manually advertise stuff with avahi, but I’m sure it’s possible.

— Ron