You are here: Home » Reply

Reply To: Anyone have a Kurobox step by step?

#8106

Digital Larry
Participant

OK, well I had to take out flac support, and used sqlite instead of sqlite3, and ran these commands you gave me, and a whole bunch of stuff happened…

So how do I know if it worked or not?

PS my existing mt-daapd was running at the time, I did shut it down, but of course now it’s shut down and nobody home at port 3689.

Rebooted box, and… it’s gone. Old one isn’t working any more.

ps -aux shows no mt-daapd processes.

README indicates need for distro-specific startup scripts.

I tried running “mt-daapd start” in /etc/init.d, but nothing happened. No console feedback nor any mt-daapd processes showing up.

Here’s what’s in the log:

2007-01-22 08:08:03 (00000400): Firefly Version svn-1489: Starting with debuglevel 2
2007-01-22 08:08:03 (00000400): Starting rendezvous daemon
2007-01-22 08:08:03 (00000400): Starting signal handler
2007-01-22 08:08:03 (00000400): Old database version: 6, expecting 13
2007-01-22 08:08:03 (00000400): Upgrading db: 6 –> 7
2007-01-22 08:08:03 (00000400): Upgrading db: 7 –> 8
2007-01-22 08:08:03 (00000400): Query: create index idx_songid on playlistitems(songid)
create index idx_playlistid on playlistitems(playlistid)
update config set value=8 where term=’version’;

2007-01-22 08:08:03 (00000400): Error: near “create”: syntax error
2007-01-22 08:08:03 (00000400): Error upgrading db: Misc SQL Error: near “create”: syntax error
2007-01-22 08:08:03 (00000400): Error opening db: Misc SQL Error: near “create”: syntax error

(which is at least something)

Any clue?