You are here: Home » Reply

Reply To: DebianSlug Arm package

#7855

mumsoft
Participant

@mas wrote:

And you will also have to check the patch up whether it does a byteswap.

I did the same ivorbis-tool patch and compile for my debian-Etch LE and these were the gotchas:

1. The patch only works against the old ivorbis snapshot as posted here. Not against an actual ivorbis snapshot. So forget the 1.1.1 version and download the old 2005er snapshot from this side.

2. The patch is IMHO (or was when I did it) for the big endian distri and has a manual byteswap in it, which will turn your music to garbage if used on a LE distribution. I manually edited the byteswap out and then recompiled. Worked perfect then.



Agenda:
1. Unpack the old ivorbis-tools snapshot
2. Run Rons patch over it
3. It only patches 2-3 files. Check these for a comment “byteswap” or similar and remove the lines after the comment.
4. Do the usual ./configure && make && make install. Voila.

Ok, thanx, now I’m getting somewhere. This looks like a cookbook.
But it is missing some ingedrients, I must say. Talking about older than vorbis-tools-1.1.1.tar.gz: on http://downloads.xiph.org, there is only a vorbis-tools-1.0.1 and no 1.0 anymore. So I googled around and found that somewhere. It dates from 2002, not 2005.
Then I applied the patch. That succeeded after entering 5 correct names. Only the dates did not match.
I found ‘byteswap’ only in oggdec.c and commented it out.
Then I compiled libvorbisidec. Second I compiled vorbis-tools-1.0. Both with –prefix=/opt
It failed with: /opt/lib/libvorbis.so: undefined reference to `lrint’

I tried several other options, but I eventually got stuck on this lrint.
I have both libvorbis and libvorbisidec installed, maybe that’s wrong?
It’s a pity that xaviour is not looking here anymore. he has a Asus WL-700gE like me and could recompile oggdec succesfully.
So somewhere is lurking a solution…

I hope you see it…

Marc