Reply To: Firefly drops off network after a few hours

#7809
cshelton
Guest

Ron,

Many thanks. I am posting what worked for me in case someone else had a similar problem and a web search brings up this page.

I made two changes. I don’t know if they were both necessary, but afterward, the problems I described were resolved:

1. I changed /etc/sysctl.conf: The line “net.ipv4.conf.all.rp_filter = 1” I changed to be “net.ipv4.conf.all.rp_filter = 0” This changes /proc/sys/net/ipv4/conf/all/rp_filter from 1 to 0 (and the change sticks after reboots). My hope was that this would turn off any IP filtering the kernel was doing. Perhaps it was unncessary.

2. I turned on permiscuous mode on the ethernet card, as suggested. Multicast was enabled, but the Roku couldn’t connect to the Kuro. Perhaps this was a temporary wireless problem, but turning on permiscuous mode worked.

-Christian