Reply To: NLSU2 nightlies issue


Firstly appologies for the length of my essays … I do enjoy writing novels!!

OK, thanks for feedback… in answer to slug qus….

Single disk ext3 or whatever it is formated by slug. Looked into overclocking slug, but think mine is a recent one running at the faster speed anyway, so don think this can be improved. (dont think performance is really an issue it streams fine, browse is the only issue)

Did notice recently on the NLSU2 page a RAM upgrade for the slug …. sounds interesting and fun, but requires a soldering iron so I think I’ll avoid unless I can get a cheap spare slug off ebay!! 😀

Anyway …. continuing my progress….

Am running NLSU slug unslung to 6.8 (or something like that)
Have roku players all running latest release software 2.5.174
Have a single PC (XP) running iTunes 6, that plays music in my office, but itunes is primarily for managing files and ID3 tags in an easyish manner.

Have been running stable 0.2.4 mt-daapd for a while, always had intermittent browse problems, and itunes m3u / xml playlists never worked properly. (the inbuilt ones were fine, but vi’ing the playlists file did get tiresome!)

Have just upgraded to nightly svn 1433 via process on firefly wiki.

Have definitely got browse problems.

Streaming works fine, playlists generaly work fine (occasionaly locks but does come back), browse works fine for a while then fails!

Have another interesting issue, the itunes can no longer connect via the mdaapd served music. Not a huge issue as I am mapped directly to the slug NAS share, but want to fix as my long term plan is to have other pc’s streaming from the mtdaapd server

Anyway coming back to the fault …….

web interface reports:

Server Status
The Firefly server is not running, this page will be inaccessible until you start the server again.Service Status Control
Bonjour Stopped
Firefly Media Server Running
File scanner Idle

Uptime 1 hour, 41 minutes, 51 seconds
Songs 16001
Songs Served 29
DB Version 2

Client IP Action Serving xml-rpc method Streaming ‘Salt Water Sound’ (id 50)

have read forums and assume bonjour stopped message to be bug.
Note : I have upped the resan interval to
as I was worried it was the scans giving me performance probs, once a day approx is fine by me, dont change music that often!

Interested in Serving xml-rpc method …. thats my itunes pc, even though its not connected that is shown all the time! Is this a prob, do I need to switch itunes off? … though thinking bout it is this just the web interface to my pc??

Get some wierd log messages, as below, some seem to relate to itunes connecting (crashes the thing generaly sometimes i have to restart server to get back, someytimes is OK)

2006-12-07 15:31:16 (00089004): Write error: Broken pipe
2006-12-07 19:20:49 (0008ac04): Unknown meta code: daap.songcategory
2006-12-07 19:20:49 (0008ac04): Unknown meta code: daap.songcontentdescription
2006-12-07 19:20:49 (0008ac04): Unknown meta code: daap.songlongcontentdescripti
2006-12-07 19:20:49 (0008ac04): Unknown meta code: daap.songkeywords
2006-12-07 19:20:49 (0008ac04): Unknown meta code:
2006-12-07 19:20:49 (0008ac04): Unknown meta code:
2006-12-07 19:20:49 (0008ac04): Unknown meta code:
2006-12-07 19:20:49 (0008ac04): Unknown meta code:
2006-12-07 19:20:49 (0008ac04): Unknown meta code:
2006-12-07 19:20:49 (0008ac04): Unknown meta code:
2006-12-07 19:20:49 (0008ac04): Unknown meta code:
2006-12-07 19:21:40 (0008ac04): Unknown meta code:

2006-12-08 04:39:14 (00000400): mDNSPlatformTimeNow went backwards by 2 ticks; s
etting correction factor to 2
2006-12-08 04:40:39 (00000400): Starting web server from /opt/share/mt-daapd/adm
in-root on port 3689
2006-12-08 04:40:39 (00000400): Registering rendezvous names
2006-12-08 04:40:43 (00000400): Serving 16001 songs. Startup complete in 95 sec
2006-12-08 04:40:43 (00000400): Rescanning database
2006-12-08 04:41:56 (00003405): Thread 10: Entering ws_returnerror (302: Moved)
2006-12-08 04:43:16 (00008806): Unknown meta code: daap.songcategory
2006-12-08 04:43:16 (00008806): Unknown meta code: daap.songcontentdescription
2006-12-08 04:43:16 (00008806): Unknown meta code: daap.songlongcontentdescripti
2006-12-08 04:43:16 (00008806): Unknown meta code: daap.songkeywords
2006-12-08 04:43:16 (00008806): Unknown meta code:
2006-12-08 04:43:16 (00008806): Unknown meta code:
2006-12-08 04:43:16 (00008806): Unknown meta code:
2006-12-08 04:43:16 (00008806): Unknown meta code:
2006-12-08 04:43:16 (00008806): Unknown meta code:
2006-12-08 04:43:16 (00008806): Unknown meta code:
2006-12-08 04:43:16 (00008806): Unknown meta code:
2006-12-08 04:43:44 (00008806): Unknown meta code:

1st scan appears OK, though some silly m3u errors, but not the issue I dont think (put in here just to check)

2006-12-08 05:02:40 (00000400): err adding playlist 90?ÇÖs Music
2006-12-08 05:02:47 (00000400): err adding playlist Recently Added
2006-12-08 05:02:48 (00000400): err adding playlist Top 25 Most Played
2006-12-08 05:03:41 (00000400): Scanned 16001 songs (was 16001) in 1378 seconds
2006-12-08 05:05:22 (00031004): Session 0: Streaming file ’06 Kashmir.mp3′ to 19 (offset 0)

playlists nearly always working (including the itunes ones!)
sometimes fails on loading songs

browse …. intermittent to say the least, pretty much broken!

think it might be to do with scans, or the multicast thing I have seen mentioned elsewhere.

while browse is failing …… playlists still work.

Initialy – Seems to reset itself after a few mins… almost as if as a scan is happening it doesnt work. After a while browse is broken completely. i.e every attemt fails with “Failed to load browse data” message on roku.

For 1st few minutes while it is working it is pretty consistent … even the browse songs function, returning 16k + resultst works (I was impressed as this has never worked before)

sometimes large browses dont work, i.e artist / album, small ones do, i.e. genres … difficult to put an exact description on this, I may be wrong.

Having attemtped to read through the forums, I am wondering if this is to do with the Multicast issues. Seems to indicate this might cause browse to fail after a while.

Not sure how I can test this, havent got tcpdump or anything on slug, how can I do a packet dump to see if multicast is working on my nw? If it isnt is there any way aroudn this.

My rokus and pc are wifi attached to a wireless LAN. The slug is directly connected to the router hub (switch … whatever not sure but it is 100M). The router is a BT voyager 2100 wireless (will go off an dig out a tech spec to see if I can find out if it supports mulicast over wireless and hub)

Once lists are loaded, streaming is fine, and very quick!

Is this something that might be fixed in a later nightly? If its the multicast issue, is there anything I can do to get around it?

Did consider going back to stable release, but playlists are just as useful as browse for the short term, so happy to continue playing around.

Note – I could do with a good guide for upgrading the nightlies.. no expert in linux, so dont understand dependancies talk!! 😳 and talk about sqllite etc. I liked the wiki guide it was v easy, but only seems to pick up 1433!

I am going off to do some tests to see if I can be more scientific about the symptoms I am seeing.

Did a

# killall -9 mt-daapd
# /opt/etc/init.d/S60mt-daapd

straight after restart of server …… browse working (I love the new udate of how many itelms downloading … not sure if its you or the roku … but nice touch)

Even the browse songs! returns …. 16000 items! (though it is noticable the roku M1000 goes a bit wobbly then for a few secs!! )

nothing in logs

Check browse every 2 mins …..

Whilst streaming music browse still works in this initial period! (slower … no real surprise there … not unusable tho)

Constantly browsinf for 20 mins all OK. (Both browse and playlists) Went off to 2nd roku doing same tests, browsing / playlists. All working OK!

Returned to 1st Roku … browse failing (was still streaming music)

then …. although intialy 1 was working 1 failing, after leaving the wokring one streaming music for a short while same happened!

Seemed to crrespond to a

2006-12-08 07:19:45 (0000cc05): Write error: Broken pipe

in the logfile.


2006-12-08 08:12:34 (0002ec08): Thread 184: Entering ws_returnerror (302: Moved)
2006-12-08 08:12:52 (00000400): Rescanning database
2006-12-08 08:14:22 (00030004): Session 0: Streaming file ’10 Beach Ball.mp3′ to (offset 0)
2006-12-08 08:14:22 (00030004): Write error: Broken pipe
2006-12-08 08:15:10 (0002c806): Thread 175: could not read: Broken pipe

Once browse broken, music continues streaming, initaly playlists failed, buit after a couple of secs, playlists started returning data

Once browse broken, nothing fixes it, roku into standby and back… still fails, restart of Roku … browse still failing!

After about 5 mins failing …… browses start working again!!

After this, difficult to describe how it does and doesnt work, sometimes roku conn to server fails completely, sometimes browse failing, sometimes works, seems to fail more than works. Sometimes streaming music “fixes” browse, sometimes doesnt.

Have noticed issues with Roku on this latest release, so maybe its more Roku than server! Seem to crash occasionaly especialy if you try and exit a browse or search, (cancel reuqest) … crashes and a power reboot is required.

Wierd Huh!!

Thanks for all the help