You are here: Home » Reply

Reply To: Problems with mt-daapd SVN nightlies on Linux

#7706

floyd

I tried building with the newer zlib and still have the same problems.
However, I noticed this time that one entry on the mt-daapd.log says
“Error in zlib: -2” so that does seem to point a finger at Zlib.

I’m not completely sure that mt-daapd is loading the new zlib.
I tried specifying the path for libid3, as suggested, as well as setting
the CFLAGS and LDFLAGS environment variable. I also added a log
trace that prints out the value of ZLIB_VERSION from zlib.h.
That indicates that at least the new version of zlib.h is being read.
However, I don’t know how to determine where it linked the library from.
I assume it’s using the shared objects. Is there a way to have mt-daapd statically link zlib.a?

I will try some more things later today or tomorrow. Perhaps temporarily
moving the old zlib files out of the way.

By the way, and perhaps unrelated: mt-daapd is unable to find or load
the sqlite3 libraries unless I configure with the option:
–with-sqlite3-libs=/usr/local/lib