Reply To: Problems with mt-daapd SVN nightlies on Linux


@floyd wrote:

I started to try older nightly versions and as far back as svn-909 I still
experience these problems. After reading some of the notes for the
nightly releases I tried rebuilding sqlite (version 3.8.8) with “threadsafe”
enabled. Now I am able to connect from iTunes but still not from the
Soundbridge or the playlist.html browser interface.

I’d probably stick with sqlite2, rather than 3, as there appears to be less volatility in the api. I’ve had much better luck with sqlite2.

I am still using some old version of some libraries but I don’t know
where to start looking for the culprit. My system is based on RedHat 6.2.
although I have been updating quite a bit of the software as the need arises.

One requirement that I didn’t realize until recently (and haven’t autoconfed for yet) is zlib >= 1.2.0. Most of the machines I’ve run it on have already been 1.2.0, so I didn’t notice it until I tried to compile it recently on an older machine. Kaboom. Segfault on connect from soundbridge.

Another possibility is that you aren’t loading the rsp plugin. If you kept your old config file, then it probably didn’t get a plugin section added, and consequently doesn’t have any output libraries.

Try going to the web interface and adding a plugin_dir. Check “/usr/share/mt-daapd/plugins”… make sure you have a bunch of so files in there, and point it there. It might also be in /usr/local/share/mt-daapd/plugins, depending on your –prefix.

I’m also having trouble tracking the various changes that have been
implemented in mt-daapd since the 0.2.4 version. So it’s hard to tell
whether the problems are all related to the change to using sqlite or
something else. Is it possible to have mt-daapd continue to use gdbm
instead of sqlite?

It will. Almost everything that was sql dependant has been factored back out, and I plan to add a gdbm backend again shortly.

I will continue to experiment with it but would appreciate any ideas
or exteriences others may have had that might provide a clue.

My money is on the zlib.

— Ron