You are here: Home » Reply

Reply To: Newbie question about using firefly on Maxtor mss+

#7489

schro20
Participant

I ran into something similar to what was reported in this thread already. I got to the ipkg step which failed. Doing route -n I see that the kernel got my gateway wrong. It thinks it is 192.168.0.0 while it actually is 0.1. Interestingly the Maxtor configuration status page lists is correctly as 0.1. I also note that it got the DNS servers correct. So it is talking to the router to get this info, but somehow gets the gateway part wrong. I don’t know how to fix this. I did a reboot to no avail. The Maxtor gets a reserved address from the router which does DHCP.

Added: I did
route add default gw 192.168.0.1

which fixed my issue. So far everything is hunky dory.

I might suggest adding this as a hint to the MSS setup page since others seem to have run into it and I had a hard time finding documentation for “route” as it exists on the MSS. The above finally worked.

I would also suggest that users who edit files on the box are reminded that it’s good practice to save the original as name.bak (or some such convention).

Ready to serve!