You are here: Home » Reply

Reply To: Newbie question about using firefly on Maxtor mss+

#7448

rpedde
Participant

@iris wrote:

@iris wrote:

executing ipkg update generates a Host Lookup failure

I checked the netowkr settings before I even started. IP of MSS through the Status page all checks out, gateway, etc. The ip is dynamic – don’t know if that’s an issue.

Try this:


# ping www.google.com
PING www.l.google.com (216.239.51.104): 56 data bytes
64 bytes from 216.239.51.104: icmp_seq=0 ttl=242 time=44.7 ms

If you get the:

PING http://www.x.google.com (###.###.###.###), then your dns is set right. If you don’t get an IP address there, then it’s likely that your dns is the problem.

We can start with the basics… what’s the IP of your PC and your router? You can find your PC settings by doing “ipconfig /all” at a dos prompt on the PC. If it’s something like 192.168.1.1 for the router and 192.168.1.100 for the PC, then the mss should be something like that as well… 192.168.1.something.

Generally, the gateway address is the address of the router: 192.168.1.1. In most home networking environments, that’s the address one should use for DNS as well.

On the mss, you can see the IP address it has by doing “ifconfig eth0” from a telnet window.

You can see the gateway by doing “route -n” and looking for the Gateway for the 0.0.0.0 destination.

You can see the dns server by doing “cat /etc/resolv.conf” and checking for a “nameserver” line.

I’d guess one of those things isn’t right, or doesn’t match your internal network settings.