You are here: Home » Reply

Reply To: Compilation problem

#7281

rpedde
Participant

@peterb wrote:

My Red Hat 9 system came with mt-daap version 0.2 installed as a package. Apart from some documented errors in the start up script, it worked OK, but I am now trying to upgrade using the source files.

These have been downloaded and unzipped, but when I issue the ./config command I get the following at the end of the system checks…

snip

Have gdbm
Adding dynamic libgdbm
checking id3tag.h usability… no
checking id3tag.h presence… no
checking for id3tag.h… no
configure: error: id3tag.h not found… try –with-id3tag=dir

end snip

There is no id3tag file or directory on my system.

I then tried

./configure –without-id3tag

but this gives gives exactly the same result. (almost as if the directive was ignored) What have I broken or what have I missed?

Can’t not have it… it needs to have libid3tag.

Basically, make sure you have libid3tag-devel or whatever your equivalent package is. You’ll also need zlib-devel and sqlite-devel.

— Ron