You are here: Home » Reply

Reply To: ubuntu 6.10 on MacMini can’t get mt-daapd to work….

#7177

rpedde
Participant

@hsl wrote:

i understand that only the last is a problem to get it to work and that i have to compile it with sqlite2 instead of 3, but I don’t have a clue how to do that, can you help me?

The other option is to have sqlite3 > 3.3.0.

I’m guessing you must have 3.2.something. This is edgy? I would have thought it would have a newer sqlite. 🙁

In any event, check the debian/rules file and make sure the configure command has both –enable-sqlite and –enable-sqlite3.

You’ll need to have libsqlite0-dev installed, and then rebuild the package.

Then just change the config file (/etc/mt-daapd.conf), and change the db_type from “sqlite3” to “sqlite”. You should be in business.

— Ron