You are here: Home » Reply

Reply To: pidof: not found

#6907

rpedde
Participant

@mvanloon wrote:

hmm the ivorbis-tools package at http://ipkg.fireflymediaserver.org/mipsel is still the arm version (at least the filename ends with armeb.ipk). The libvorbisidec package is also armeb (libvorbisidec_cvs-20050221-1_armeb.ipk). The rest is all mipsel.

Okay… they are fixed.

Here’s my quick notes:

Install openmss 2.6.2

Use web interface to turn off media sharing or whatever (Shared Folders -> Manage Digital Photos etc -> Disable Media Server)

telnet to slug and start installing packages:


# cat src nslu2 http://ipkg-us-dyoung.nslu2-linux.org/feeds/optware/mss/cross/unstable > /opt/etc/ipkg.conf
# cat src firefly http://ipkg.fireflymediaserver.org/mipsel >> /opt/etc/ipkg.conf
# ipkg update
# ipkg install mt-daapd
# ipkg install nano
# LD_LIBRARY_PATH=/opt/lib /opt/bin/nano /opt/etc/init.d/S60mt-daapd

change the line that reads:

/opt/sbin/mt-daapd….

to:

/opt/bin/ld.so.1 /opt/sbin/mt-daapd…

Once this is done, turn off the built-in bonjour advertising:

# LD_LIBRARY_PATH=/opt/lib /opt/bin/nano /shares/mss-hdd/__bonjour/etc/rendezvous.conf

Find the lines for _tcp._daap and get rid of them (3 lines or something).

save the file, restart. /opt/etc/init.d/S60mt-daapd and it should fire right up with no songs. Go to the web interface and configure mp3 dirs and whatnot… (/shares/mss-hdd/Public/Our Music, maybe?)

I’m listening to music streaming off mine right now…

— Ron