You are here: Home » Reply » Reply To: Web interface & Firefox

Reply To: Web interface & Firefox

#6566
CCRDude
Participant

Update: server restarted, no change.

The stylesheet is in it’s place, I can open it if I enter it’s address directly into the browser.

Idea: 9 HTML warnings… if you use XHTML Strict, you should follow the standard, otherwise use HTML Transitional 😉 The complete HTML header is invalid due to the (null)s, so maybe that’s why Firefox, strictly following the rules, doesn’t load the stylesheet?

I used the tarball with ./configure –enable-oggvorbis –enable-flac –enable-musepack –enable-sqlite. I had a 0.2.4 on the machine before that.

BUT: If it was a version mismatch, why would it work when I access it through Internet Explorer? I tried Firefox on another machine as well – same problems (all Firefox installations so far had Adblock and NoScript, but those are really two of the most-used Firefox installations).

I went and deleted the contents of /usr/local/share/mt-daapd/admin-root (where my mt-daapd.conf points to for the webroot), and copied the contents of mt-daapd-svn-1376/admin-root into that folder. I cleared the browser cache and accessed it again – same error.

I then used chmod to root:root and chown to 555 on the whole admin-root folder (the permissions and owners from the tarball where quite mixed) – no change.

I used locate smartpopup.html to see if any other directories exist (in case the webroot parameter wouldn’t be working) – that’s not the case.

The only executable I found is /usr/local/sbin/mt-daapd. It’s really to bad it doesn’t show any version :-/ But the file date is September 7, so it’s the result of my SVN installation (config.status in the svn folder etc. have the same date).

My final conclusion would be the (null)s in the header again:


Firefly Media Server


(null)
(null)




(null)
(null)

(null)
(null)

(null)
(null)


Looks very much like under some conditions, ispage is returning (null) instead of an empty line. And comparing that to the hdr.html, I found a possible explanation for that:
* On the current page, the line is written, but cut too early, after character 62!
* On other pages ispage, src-fields with a file in the same folder return an empty line, and
* src-fields with a file in a subfolder return (null).