You are here: Home » Reply » Reply To: again: Error opening db: No backend database support….

Reply To: again: Error opening db: No backend database support….

#5211
t0m
Participant

@andrews wrote:

I believe the mt-daapd.conf is in /usr/local/etc by default now

yes – that’s where my conf is 😉

@rpedde wrote:

As far as t0m’s problem — the config file got moved to an ini-style format… so you have stuff like:

mp3_dir /path/to/mp3
something_else /blah/blah/blah

right?

And then you added:

db_type = sqlite

so it’s trying to open a db type of “=sqlite”, not “sqlite”.

exactly .. that’s been the error…

Easiest thing to do is to convert your config file:


mt-daapd -v -c /path/to/mt-daapd.conf

and it should then be in .ini format, then edit the db stuff.

that gave me the error:


setting dest to 4
Converting config file...
Error writing config file.

but the file was converted right.

thanks for you help

/t0m