You are here: Home » Reply » Reply To: nightlies aren’t working for me since 909

Reply To: nightlies aren’t working for me since 909

#5037
rpedde
Participant

@patzerbud wrote:

Error opening db: No backend database support for type: sqlite

However, I’m specifying –enable-sqlite3 when invoking configure.

There are two different versions of sqlite… sqlite 2.8.x, and sqlite 3.x. If you are using –enable-sqlite3, then you want the db_type to be sqlite3. If you use –enable-sqlite, then you want the db_type to be sqlite.

So you are telling you want sqlite 2.8, but you only compiled in sqlite 3.x.

Change your db type, and you should be in business. If you see strange db problems, though, try switching to 2.8. Unless you have a really new sqlite3, you might have problems.

— Ron