You are here: Home » Reply » Reply To: 1197 – ogg support

Reply To: 1197 – ogg support

#4961
rpedde
Participant

@indridi wrote:

well… it works up to the oggvorbis support. The server does not index any .ogg files, which is rather annoying since most of my music collection is in .ogg.
Actually, this symptom also exists in 0.2.4, but there it indexes the ogg-files, but doesn’t read the tags, so I have lots of music by “unknown” in my collection. Is it possible that there is something wrong with my files, or maybe some libraries on my machine, or are others experiencing the same behaviour?
Help would be appreciated.

Other than that (!), great work, just stumbled upon this two days ago,
and it seems like a brilliant piece of software.

(and for the record, I have set the appropriate “extensions” option in my config file)

thanks
IndriĆ°i

you’ll need libogg, libvorbis, and libvorbisfile. then configure with “–enable-oggvorbis”. Delete your songs.db to force a re-index and you should see the stuff okay.

You’ll still need to get the transocoding set up (if you haven’t already), but that will get your metadata.

— Ron