You are here: Home » Reply » Reply To: svn-1082: Art(not)work?

Reply To: svn-1082: Art(not)work?

#4729
rpedde
Participant

@pnose wrote:

I finally managed to install svn-1082 on my Solaris10/sparc box and it seems to work even w/ the small changes I made in src/xml-rpc.c in order get it compiled. Coming from 0.2.4 it’s really cool to see and use all the new features. Thanks for all the work, Ron! 🙂

I actually *have* a solaris machine, but I haven’t built on it in a few weeks, so I’m working toward clean builds out of the box on solaris 10.

But one thing is missing which did work with my 0.2.4 installation: The artwork doesn’t show up in iTunes (6.0.4.3) anymore, even though it’s mentioned in the log, e.g.:

Yeah, the art stuff is specific to the tag version. I’m debating what to do with that code. It’s a neat feature, but it’s broken, and it really is intrusive and ugly code-wise.

I’m actually debating axing it, but I get flamed every time I say something like that. :-/

I’m going to have to wrestle to see if i can come up with a decent way to implement that.

Is this a general problem with svn or 1082 or did I break something in xml-rpc.c? If the latter, how can the source be compiled w/o d_type on the pde-structure? :-/
[/quote]

Should be unrealted to d_type.

But no d_type in dirent?!?! Back to stat, I guess.

— Ron[code]
Is this a general problem with svn or 1082 or did I break something in xml-rpc.c? If the latter, how can the source be compiled w/o d_type on the pde-structure? :-/
[/quote]

Should be unrealted to d_type.

But no d_type in dirent?!?! Back to stat, I guess.

— Ron