You are here: Home » Reply

Reply To: XBMC

#4658

eschoeller
Participant

I can connect to firefly with no problems from xbmc. And I can view play lists and the library. The second i select any of the songs and try to play them, xbmc freezes. Most songs I have are FLAC, but the same behavior exists with other formats (mp3).

Here are the logs from a -d8, when xbmc connects


2007-03-03 00:46:16 (78a7a890): Request: GET /server-info HTTP/1.1
2007-03-03 00:46:16 (78a7a890): Request: GET /content-codes HTTP/1.1
2007-03-03 00:46:16 (78a7a890): Request: GET /login HTTP/1.1
2007-03-03 00:46:16 (78a7a890): Request: GET /update?session-id=2&revision-number=1 HTTP/1.1
2007-03-03 00:46:16 (78a7a890): Request: GET /databases?session-id=2&revision-number=5746 HTTP/1.1
2007-03-03 00:46:16 (78a7a890): Request: GET /databases/1/items?session-id=2&revision-number=5746&meta=dmap.itemid,dmap.itemname,daap.songalbum,daap.songartist,daap.songbeatsperminute,daap.songbitrate,daap.songdisccount,daap.songdiscnumber,daap.songgenre,daap.songsamplerate,daap.songsize,daap.songtime,daap.songtrackcount,daap.songtracknumber,daap.songuserrating,daap.songyear,daap.songformat HTTP/1.1
2007-03-03 00:46:17 (78a7a890): Request: GET /databases/1/containers?session-id=2&revision-number=5746 HTTP/1.1
2007-03-03 00:46:17 (78a7a890): Request: GET /databases/1/containers/1/items?session-id=2&revision-number=5746 HTTP/1.1
2007-03-03 00:46:17 (78a7a890): Request: GET /databases/1/containers/2/items?session-id=2&revision-number=5746 HTTP/1.1
2007-03-03 00:46:17 (78a7a890): Request: GET /databases/1/containers/3/items?session-id=2&revision-number=5746 HTTP/1.1
2007-03-03 00:46:17 (78a7a890): Request: GET /databases/1/containers/4/items?session-id=2&revision-number=5746 HTTP/1.1
2007-03-03 00:46:17 (78a7a890): Request: GET /databases/1/containers/5/items?session-id=2&revision-number=5746 HTTP/1.1
2007-03-03 00:46:19 (d386147f): Request: GET /spinner.gif HTTP/1.1
2007-03-03 00:46:20 (d386147f): Request: GET /xml-rpc?method=stats HTTP/1.1

There is no output in the logs when xbmc tries to play a song.
tcpdump doesn’t pick anything up either.

I am running a build of xbmc from Jan 27 2007.

I’ll try upgrading to a newer version if I can find one, and post my results. Does anyone else have a similar problem?[/quote]