You are here: Home » Reply » Reply To: Mt-daapd can’t find my mp3

Reply To: Mt-daapd can’t find my mp3

#4412
rpedde
Participant

@svizi wrote:

Should i remove the .deb package ( don’t know how ) and install it manually?

You have two problems. One is that when you ran it as you, it bumped into the version that the system started. That’s problem number one.

Problem number two is that the system version is running as “nobody” but trying to read mp3 files that are sitting in your home directory. “nobody” doesn’t have permission to read files in your home directory, so it doesn’t find any files.

Two options:

change the “runas” user to your username, so it runs as you can access the mp3 files, or move the mp3 files out of your home directory to somewhere where you can set read permissions to everyone.

Simple answer is probably the prior, better answer is probably the latter.

Either way works, though.

When starting or stopping, you should be doing:


/etc/init.d/mt-daapd start

and

/etc/init.d/mt-daapd stop

as root.

This should help.

— Ron