Reply To: problems with win32 port

#3987
politby
Guest

rpedde wrote:

There are two styles of the config file. If it is in the windows .ini format, i.e. if the first non-comment line is a section header, then it expects it in key = value format. If there is no section header, it’s in “compatibility” mode, and it doesn’t expect an =.

I need to divert logging to the eventlog before it reads the config file, but that’s the issue.

My suggestion would be to use the same technique as before: run it in the foreground and see what it’s mad about. “c:program filesmt-daapd -d9 -f”

— Ron

Turns out that the db_parms parameter in my config file had a final “” at the end of the path:

db_parms=D:MediaMy Musicmt-daapd

That caused the process to crash. πŸ™‚

Removing the last so that it reads

db_parms=D:MediaMy Musicmt-daapd

cured the problem. Apparently mt-daapd doesn’t want Windows paths to end with “”.

/POL