You are here: Home » Reply

Reply To: mt-daapd only scans once after startup

#3193

rpedde
Participant

Well… let’s see.

You could start by forcing a scan from the web interface, just to make sure it’s working. Add an mp3 file or change an mp3 file’s name so that it’s not an mp3 file anymore and make sure it drops off the server list. That will ensure that the scan is really happening and nothing crazy is going on.

You could also change the config file to have a logfile parameter. (I use /share/hdd/data/public/mt-daapd.log so I can see it from a smb mounted share) then edit /opt/etc/init.d/S60mt-daapd and add a -d9 to the command that starts it. start up the server, wait for it to finish scanning, and stop it.

Then check the log file. right at the start, it should dump everything it read from the config file. See if it’s reading it right from the config file.

If not, check typos, check to make sure there aren’t any trailing spaces in the command, and make sure it’s 600, not 6000 or something obvious like that.

That’s about all I can think of off the top. Try that, and see where that leads you.

— Ron