You are here: Home » Reply

Reply To: Installing Firefly on Embedded System

#18639

Anonymous

Thanks! I ran into an issue with some of the paths referenced in the config file. Changing those paths fixed my problem. Sadly, that has exposed another problem. The system i am working with is a single user linux system, and trips up on the “runas”. Here’s the error i run into:


# ./mt-daapd -c /etc/mt-daapd.conf -f -d 5
Loading new config file.
Firefly Version svn-1696: Starting with debuglevel 5
Loaded plugin /lib/mt-daapd/plugins/out-daap.so (daap/svn-1696)
Loaded plugin /lib/mt-daapd/plugins/rsp.so (rsp/svn-1696)
Loaded plugin /lib/mt-daapd/plugins/ssc-script.so (ssc-script/svn-1696)
Plugin loaded: ssc-script/svn-1696
Plugin loaded: rsp/svn-1696
Plugin loaded: daap/svn-1696
Starting rendezvous daemon
Starting signal handler
Couldn't lookup user root
Error in drop_privs: No such file or directory
Aborting

I traced the error down to the function “getpwnam” in the file pwd.h in /usr/include (on ubuntu). The issue being that my system doesn’t have that file or the package it goes with. Because this is a single user system, a workaround where we simulate a multi-user system for the use of firefly is not desirable. Is there a way to remove the user lookup functionality in order to circumvent this error? Or is there another option that i am currently missing?