You are here: Home » Reply

Reply To: Firefly not showing up as "Shared" in iTunes

#18515

garydauphin

I, too, am having the exact same issue. I found a fix, though it is not yet elegant:

I wrote a two line script that stops the server and then immediately restarts it.

sudo /etc/init.d/mt-daapd stop
sudo /etc/init.d/mt-daapd start

I saved this as a text file as “Restart FireFly.sh” and set the Permissions to make the file executable. Now when I double click it, it asks me if I want to run this in the Terminal,and I click Run in Terminal. It fixes the problem every time.

Now you might think that all it does it restart a dead mt-daapd process, but if I leave out the STOP command, and just put the START command, it doesn’t work. So, something about stopping a running server and restarting it fixes the problem every time.

The downside is that I have to manually enter the sudo Password everytime.

I tried taking out the “Sudo” so it would need a password from me, and then having the script run every time I login:

System -> Preferences -> Startup

Here I noticed that the Mt-daapd or Firefly was not listed to automatically startup. So, I added my script to the list of startup items.

Well, this worked for one run, then upon restart it wouldn’t work. The script would always STOP mt-daapd every time without SUDO, but it didn’t seem to START it again afterwards. To test, I put sudo back in there, and it worked perfectly.

So, I am thinking you need sudo privileges to run
/etc/init.d/mt-daapd start

I went looking for that file, which turns out to be a config script that launches

/usr/sbin/mt-daapd So, I was hoping that I gave permission to run that app without being sudo, all might be well:

If foudn that this an executable binary, but only executable by root. So, I went to the terminal and set it read / write for my user:

sudo chmod 777 /usr/bin/mt-daapd

Well that, too, worked during one session, but upon reboot, didn’t work again without Sudo being in there.

gd