You are here: Home » Reply

Reply To: Multicast routers

#18279

andyg
Participant

Werg,

I have this model of Belkin router

runtime Code version	 F5D7633-4Av1_UK_1.00.17

which powers my main slug setup. Firefly on slug shows up perfectly on a wireless Mac in iTunes. Equally I don’t see any multicast option in the router menus, but first up try switching to a different channel from the default.

Then, if possible or something similar:

Under Wireless> Channel & SSID
have: 54g-auto enabled 54g protection ON Turbo Mode – Frame-bursting Mode

If there is some other mixed-mode option, check it as your Roku is a b-mode device.

you don’t mention the Roku’s location relative to the router. Bear in mind walls, distance & other interference/environmental factors which may have a bearing on things…

andy