You are here: Home » Reply

Reply To: Bad mp3 directory on mt-daapd startup – stumped

#18275

EVILRipper
Participant

Don’t really know if this will help, but I had a similar problem.
I mounted my usb hard disk using /etc/fstab .
My guess is that that harddisk is formatted in FAT as windows and linux both have no trouble using it.
(FAT in linux is sometimes known as vfat)
When mounting a FAT harddisk, you can determine the permissions in /etc/fstab.

If you run ‘man mount’ you get the manpage for the mount option.
These static mount options are determined in the /etc/fstab when booting.
When you scroll down the manpage, near line 412, there are specific “Mount options for fat”.
The umask determines the permissions for the mounted drive.

Not sure whether this would be useful for your situation, but at least I tried. 🙂