You are here: Home » Reply

Reply To: Connection failed to firefly-instance on Maxtor(please help)

#17366

RickV
Participant

After deleting the ipkg.conf I thought I did exactly that is mentioned in the wiki.

I checked the wiki again and I found that I forgot to do the following change:

LD_LIBRARY_PATH=/opt/lib /opt/bin/nano /opt/etc/init.d/S60mt-daapd
/opt/lib/ld.so.1 /opt/sbin/mt-daapd -c /opt/etc/mt-daapd/mt-daapd.conf

So I did now and then did a power-down on the maxtor. After power-up I started the server with the following result:

# /opt/etc/init.d/S60mt-daapd
# pidof: not found
pidof:: not found
/opt/sbin/mt-daapd: error while loading shared libraries: libFLAC.so.8: cannot open shared object file: No such file or directory

With a search on the forums I found Ron’s advice , but that resulted in the following:

# ln -s /opt/lib/libFLAC.so.8 /opt/lib/libFLAC.so.7
ln: /opt/lib/libFLAC.so.7: File exists

Starting the server results in the same error as above.

Without exactly knowing what I’m doing I also tried:

# ln -s /opt/lib/libFLAC.so.8 /opt/lib/libFLAC.so.8

This gave no error/warning but starting the server results in the same error as mentioned above.

You are saying:

Did you set the correct LD_PATH in the init script

Where do I set it?