You are here: Home » Reply

Reply To: Solved: MDNS not working in svn-1696

#16541

skellert
Participant

I ended up building another system and configuring it as closely as possible to the first that wasn’t working. Of course, mt-daapd worked fine so I started changing hardware between the two systems until the new one broke and the old one worked….

My ethernet card was the culprit. But why does it work with tcpdump running?

After uber-googling, I discovered that tcpdump puts an ethernet card into promiscuous mode. I also discovered that some ethernet cards don’t recognise multicast UNLESS you manually put them into promiscuous mode. Duh.

The mt-daapd internal mdns then works fine when the card is put into promiscuous mode….

ifconfig eth1 promisc

When the ethernet card is in promiscuous mode, you can do an ifconfig eth1 and you’ll see the PROMISC flag listed. Also, if you do a dmesg | grep eth1, you’ll see the log that the card has been placed into promiscuous mode.

Hope this saves somebody else a week of sleepless nights.