You are here: Home » Reply

Reply To: Solved: MDNS not working in svn-1696

#16538

skellert
Participant

I seem to be musing a lot to myself in this thread….

My old Fedora 7 server was a slow P3-700. The new fedora 8 server is a VIA Esther 1.5G and so quite a bit faster.

The bizarre result that mdns works OK when tcpdump is running on the same machine, but not ok if tcpdump is not running threw me – but perhaps this is CPU related – with tcpdump running, the cpu is busy writing packets to a file when there’s mutlcast traffc going in and out. This is not the case if tcpdump is not running. On the old computer, the CPU was slower anyway etc etc.

I wonder whether there’s a race happening inside the MDNS code?

This might also explain the bizarre behaviour of different outcomes when running -d 0 and -d 9 debugging… which I didn’t provide a lot of detail about in the previous posts, but believe me, its different.

For grins, I tried a few other releases – eg svn-1586 and 0.2.4.1 – they behaved differently – but still mdns didn’t work. Perhaps there’s been some race condition for a while affecting fedora that I’ve not picked up because my server was so slow in the past??