You are here: Home » Reply

Reply To: My Book World Edition Set UP Woes!

#16496

wesswei

@atomoverride wrote:

Wow no responses yet?

I’m not sure if you’re still in need here, but I’ve managed to get my NAS up and running with Firefly installed. I’m using the NSLU2 (gumstix) for my MBWE.

I’ve installed all of it using completely OPT. I tried compiling as described in the wiki, but to no avail. I got the same error message as you. In fact after compiling each of the required libraries, more errors would surface. I soon just used opt.

The packages you need in opt are the same needed for compiling.

ipkg install zlib libid3tag sqlite mt-daapd-svn

you have to use the mt-daapd-svn version as opposed to the mt-daapd because the later is precompiled for use with sqlite.

Oh, I think one last step was to create symbolic links of all the libs in /opt/lib to /lib

you can do that with sudo ln -s {from} {to}
with {from} being the libs in /opt/lib and {to} the libs referenced in /lib

Anyway, I have it running now. My only problem is permissions. I have my box to need passwords for samba shares, which is owned by the user (me). I’ve tried chmod and chown but i’m not certain what the directory’s permissions and owners should be. Or maybe adding a user to a group. I don’t know. In any case, it runs, displays a shared playlist on itunes. I just need to make it recognize my mp3s, which I can do very simply by moving the entire library to another directory outside of the private samba share. just dont want to do that.

Hope this helps. Let me know if it does…