You are here: Home » Reply

Reply To: Broken Pipe / 401 Unauthorised when using correct password

#15774

rpedde
Participant

@icephyre wrote:

Hey guys, i’m running 2.4.1 on a Solaris Express (Solaris 11) machine… in -d 9 mode i can see that my database starts up and songs parse, my config file (including correct password) are being read… however i go to the web interface, and it asks me for my password, but just keeps asking for authentication without going any further, even though i enter the right password… or even the default one for that matter.

Thread 6: Entering ws_dispatcher (Connection from 192.168.10.4)
Thread 6: got request
Request: GET / HTTP/1.1
Thread 6: Read: Host: mrbig:3689
Thread 6: Adding header *Host=mrbig:3689*
Added *Host=mrbig:3689*
Thread 6: Read: User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Thread 6: Adding header *User-Agent=Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11*
Added *User-Agent=Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11*
Thread 6: Read: Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Thread 6: Adding header *Accept=text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5*
Added *Accept=text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5*
Thread 6: Read: Accept-Language: en-us,en;q=0.5
Thread 6: Adding header *Accept-Language=en-us,en;q=0.5*
Added *Accept-Language=en-us,en;q=0.5*
Thread 6: Read: Accept-Encoding: gzip,deflate
Thread 6: Adding header *Accept-Encoding=gzip,deflate*
Added *Accept-Encoding=gzip,deflate*
Thread 6: Read: Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Thread 6: Adding header *Accept-Charset=ISO-8859-1,utf-8;q=0.7,*;q=0.7*
Added *Accept-Charset=ISO-8859-1,utf-8;q=0.7,*;q=0.7*
Thread 6: Read: Keep-Alive: 300
Thread 6: Adding header *Keep-Alive=300*
Added *Keep-Alive=300*
Thread 6: Read: Connection: keep-alive
Thread 6: Adding header *Connection=keep-alive*
Added *Connection=keep-alive*
Thread 6: Read: Cache-Control: max-age=0, max-age=0
Thread 6: Adding header *Cache-Control=max-age=0, max-age=0*
Added *Cache-Control=max-age=0, max-age=0*
Thread 6: Read: Authorization: Basic YWRtaW46cHZkODA4
Thread 6: Adding header *Authorization=Basic YWRtaW46cHZkODA4*
Added *Authorization=Basic YWRtaW46cHZkODA4*
Thread 6: Read:
Thread 6: Headers parsed!
Checking to see if connection matches close
Thread 6: Connection type HTTP/1.1
: Connection: persist
Thread 6: Original URI: /
Thread 6: Translated URI: /
Thread 6: Preparing to find handler
Thread 6: URI Match!
Thread 6: Time is 1199853293 seconds after epoch
Thread 6: Setting time header
Added *Date=Wed, 9 Jan 2008 04:34:53 GMT*
Added *Connection=keep-alive*
Added *Server=mt-daapd/0.2.4.1*
Added *Content-Type=text/html*
Added *Content-Language=en_us*
Thread 6: Using non-default handler
Preparing to decode YWRtaW46cHZkODA4
Decoded admin:asdf
Decoded user=admin, pw=asdf
Added *HTTP_USER=admin*
Added *HTTP_PASSWD=asdf*
Added *WWW-Authenticate=Basic realm="webserver"*
Thread 6: Entering ws_returnerror (401: Unauthorized)
Updating Connection from keep-alive to close
Emitting reponse header WWW-Authenticate: Basic realm="webserver"
Emitting reponse header Content-Language: en_us
Emitting reponse header Content-Type: text/html
Emitting reponse header Server: mt-daapd/0.2.4.1
Emitting reponse header Connection: close
Emitting reponse header Date: Wed, 9 Jan 2008 04:34:53 GMT
Entering config_set_status
Exiting config_set_status
Thread 6: Terminating
Thread 6: Freeing request headers
Thread 6: Freeing response headers
Thread 6: Freeing request vars
Thread 6: Closing fd
With thread 6 exiting, 0 are still running

The library also doesn’t come up in iTunes yet…

I’m running the latest libid3tag, libmad, howl, and the sqlite3 and gdbm from sunfreeware

Also, i compiled with –enable-sqlite3, but the file in /var/cache/mt-daapd is songs.gdb, not songs.db… am i barking up the wrong tree or is sqlite3 not kicking in?

Are you sure that you are entering the admin_pw, and not the music password?

For he sqlite thing, 0.2.4 doesn’t support sqlite, only gdbm. The nightlies support sqlite. Also, the 0.2.4 mdns responder doesn’t seem to work on solaris 10/nevada. You’ll want to use nightlies and configure with –enable-howl.

Last stable nightly was 1586, available at http://nightlies.mt-daapd.org/?limit=9999

— Ron