You are here: Home » Reply

Reply To: A standalone Java client: FireflyClient

#15693

Anonymous

I’m having a frustrating problem using the Java Firefly client, and I can’t determine (with confidence) whether the problem is related to Java, or to the Firefly client. I’ve found countless mentions of the problem online through Bing and Google, but nothing I’ve found has led to an effective solution.

I cannot run the .jar from the Windows GUI.

* I’m running Windows 7 (64-bit).
* I’ve downloaded FireflyClient-v0.9b-20081231.jar .

Before beginning this process, I had Java – J2SE Runtime & Dev Kits version 1.50.220 installed.

No file association or filetype existed for .jar files.

I added the file associations and filetypes.

Next, I downloaded and installed Java 6 Update, version 6.0.180.

The problem remains.

If I double-click the .jar file, I see this error:
“Could not find the main class. Program will exit.” The title of the error window is “Java Virtual Machine Launcher”.

The error seems to suggest to me that the problem is that the .jar file doesn’t specify the main class properly.

BUT, if I open a command prompt window and enter this command:

javaw -jar FireflyClient-v0.9b-20081231.jar

Then, the program opens and runs fine.


C:UsersSteveDownloads>assoc .jar
.jar=jarfile

C:UsersSteveDownloads>ftype jarfile
jarfile="C:Program FilesJavajre6binjavaw.exe" -jar "%1" %*

I’ve tried changing the ftype to run java.exe instead of javaw.exe, and also tried removing the %* characters from the end of the line.

I don’t understand why the program runs perfectly fine if I launch it from the command line myself, yet if I try to run it by double-clicking I get the error, considering that the ftype seems to be running the same command I run manually.

Looking at my PATH variable, the path included the 1.5.0.22 jdk, not the jre6 directory. I changed the ftype to use that javaw.exe, so that the command-line and GUI would use the same javaw.exe, and I still see the same discrepancy – I can’t start the program from a double-click, getting the error described above, yet running the above command from the console starts the program just fine.

I’m stumped. Help?

Thanks,
Steve