You are here: Home » Reply » Reply To: What version am I running?

Reply To: What version am I running?

#14591
rpedde
Participant

@Franc wrote:

Hi,

Have firefly running on my Windows XP machine, but it is serving songs that are actually on a linux machine.
So I figured why not run it on the linux machine directly. It’s a ClarkConnect 3.2 box with a couple of add-ons.

So I went to RPM find and searched for ‘firefly’ but that turned up nothing.
So I remembered this server used to be called mt-daap so I searched for that and found:

mt-daapd-0.2.4-1.fc4.i386.rpm

Tried to install it but it told me I was missing stuff.
So I patiently installed it all(
howl-0.9.8-3.i386.rpm
howl-libs-0.9.8-3.i386.rpm
libid3tag0-0.15.1b-4mdk.i586.rpm
libid3tag-0.15.1-3.b.i386.rpm
)
The I could finally install mt-daapd.
Started it and the webpage came up but nothing was served.
By coincidence I found out that I had to start
nifd
mDSNResponder
also by running
/etc/rc.d/init.d/nifd start
/etc/rc.d/init.d/mDNSResponder start
And now it servs songs well 🙂
(kinda hoping the fact that the files are in rc.d/init.d means they will start at bootup??)

But what version am I running now? Is 0.2.4.1 of daap the same as 0.2.4.1 of firefly? Do I have the same functionality as on my WIndows XP version?

EDIT: except for the fact that my SOundBridge doesn’t recognise it as compatible server 🙁

Right… 0.2.x doesn’t have rsp, that’s only in the nightlies. And I don’t have RPMs for those yet.

— Ron