You are here: Home » Reply » Reply To: Win XP setup problems – Firefly won’t start

Reply To: Win XP setup problems – Firefly won’t start

#14409
rpedde
Participant

@slarty101 wrote:

Hi complete noob here so apologies in advance as I’m probably doing something really stupid! I downloaded the latest nightly for Win XP (build 1696) but cannot get the server to start.

Here’s what i did:
1. turned win xp firewall off
2. downloaded and installed Bonjour 1.4
3. downloaded and installed Firefly svn -1696
4. tried to start server via tray icon – no go
5. tried to start web interface – no go

O/S: Win XP media centre sp2
network: wireless using Belkin FSD 736-4 wireless modem and router
hardware: Acer Aspire 5100 laptop dual AMD TL-50 / 1 gig ram

Firefly log:

Log file: firefly.log

2007-11-13 11:00:51 (82ebf492): Firefly Version svn-1696: Starting with debuglevel 2
2007-11-13 11:00:51 (82ebf492): Plugin loaded: ssc-wma/svn-1696
2007-11-13 11:00:51 (82ebf492): Plugin loaded: ssc-ffmpeg/svn-1696
2007-11-13 11:00:51 (82ebf492): Plugin loaded: w32-event/svn-1696
2007-11-13 11:00:51 (82ebf492): Plugin loaded: daap/svn-1696
2007-11-13 11:00:51 (82ebf492): Plugin loaded: rsp/svn-1696
2007-11-13 11:00:51 (82ebf492): Starting rendezvous daemon
2007-11-13 11:00:51 (82ebf492): Building drive mapping table from C:Program FilesFirefly Media Servermapping.ini
2007-11-13 11:00:52 (82ebf492): Error: enum_begin failed (error 1): Misc SQL Error: no such table: config
2007-11-13 11:00:52 (82ebf492): Can’t get db version. New database?
2007-11-13 11:00:52 (82ebf492): Initializing database
2007-11-13 11:00:52 (82ebf492): Error: enum_begin failed (error 1): ?
2007-11-13 11:00:52 (82ebf492): Error: enum_begin failed (error 1): ?
2007-11-13 11:00:52 (82ebf492): Full reload…
2007-11-13 11:00:53 (82ebf492): Starting mp3 scan
2007-11-13 11:01:19 (82ebf492): Starting playlist scan
2007-11-13 11:01:19 (82ebf492): Updating playlists
2007-11-13 11:01:19 (82ebf492): Scanned 1049 songs in 26 seconds
2007-11-13 11:01:19 (82ebf492): Starting web server from C:Program FilesFirefly Media Serveradmin-root on port 9999
2007-11-13 11:01:20 (82ebf492): Listen port: An attempt was made to access a socket in a way forbidden by its access permissions.
2007-11-13 11:01:20 (82ebf492): Error starting web server
2007-11-13 11:01:20: Aborting

Is it just something really stupid regarding file permissions or default ports? I haven’t got as far as trying to connect to my Pinnacle SoundBridge yet!

Any help greatly appreciated.

Thanks in advance,
S.

You have something else running on port 9999. Try changing the port in the tray applet to something else and restarting it.

— Ron