You are here: Home » Reply » Reply To: symbolic link is not detected on NAS

Reply To: symbolic link is not detected on NAS

#14297
rpedde
Participant

@fizze wrote:

well, you do not need symbolic links, just add another mp3 directory.
Unless you are using 0.2.4 of mt-daapd, this should work alright.

What version are you using?

While it’s almost certainly a permissions issue (your music directory isn’t world readable), there is also a config option to control whether or not it follows symlinks when scanning. Default iirc is 1. But worth checking.

Also, probably the “real” solution is to have the server run as your user, as your user put the data there, so can certainly read it.

Check /etc/passwd and see what your unix username is and change the “run_as” user to that. Should fix you up.