You are here: Home » Reply

Reply To: firefly & itunes ‘view options’ state, txtvers=1 option

#12994

rpedde
Participant

@barunio wrote:

hi ron —

thanks for the help.. i tried to install the latest nightly .deb file using the ubuntu package installer (the default option when clicking on the .deb file in firefox). it seemed to install ok, but running mt-daapd from the command line still seems to launch the 0.2.4 version.

“which mt-daapd” shows me that it’s launching the program from /usr/local/sbin/mt-daapd

from the “included files” in the package installer, it seems like the newer version is located in /usr/sbin/mt-daapd
but if i try running “/usr/sbin/mt-daapd -y” from the command line, nothing happens.

i’m missing something really simple here, it seems. what do i need to do to launch the newer version that i installed? (where would it be located?)

thanks..

apt-get remove –purge mt-daapd

to get rid of the packaged version you tried to install.

Then clean up all the old stuff. Delete the old files, the old config file, the init script in /etc/init.d/mt-daapd. Get rid of it all. If you leave stuff lying around from an unpackaged install, it will keep the package from overwriting stuff, which will (as you saw) keep the “new” files from installing.

Once you’ve completely uninstalled the old version, then install the package again, edit the config file to taste, and it should start up.

— Ron