You are here: Home » Reply

Reply To: Stream to a remote iTunes

#12960

rpedde
Participant

@iris wrote:

@fizze wrote:

You sure that you run that all as root?
tried to reboot the slug?

Did you run ipkg update / ipkg upgrade?

Tried to run ipkg with more verbosive error messages?

I guess you lack some deps, or some deps are not met with the proper version.

Strangely enough though, I never had any problems at all running ipkg install openssh on a fresh unsling slug.
🙄

Yes Yes and Yes

The only thing that I gleaned from the verbose message is that the files contained no MD5SUms. I even tried installing an older version.

I’m assuming this is an mss. The mss’ are kind of funky because there apparently isn’t a fully compatible build system. The libraries and stuff from unslung are incompatible with the files on the mss. Not sure why, but it makes it really hard to work on the mss. Too bad, because it would be my first choice as a nas if it weren’t for that situation.

You can try setting your LD_LIBRARY_PATH to /opt/lib and your path to put /opt/bin and /opt/sbin/ first:


# export LD_LIBRARY_PATH=/opt/lib
# export PATH=/opt/bin:/opt/sbin:$PATH
# ipkg install openssh

That might do it.