You are here: Home » Reply

Reply To: LAN Incompatibility?

#12700

rpedde
Participant

@tsimon wrote:

Background:
I Currently have two mt-daapd servers running. One is an old dell 2300 with a standard 10/100 NIC card. The standard mt-daapd install from the Feisty repository worked great. In an effort to curb my power consumption I picked up one of those little Jetway mini-itx boards with an integrated Dual Realtek LAN chip 10/100/1000 (RTL8110SC).

I repeated this same install process that worked before without success. I believe the problem is related to the chip dropping multicast packets. I’ve tried several solutions listed in the forums including: putting the card into promisc mode, clearing out iptables and changing the default policy to accept, installing different nightly builds, and recompiling the the LAN driver from the source found on realtek’s site (which made everything worse).

Problem:
The most common problem I’ve had (with the new jetway mobo) is iTunes cannot find the mt-daapd server after you close and reopen the application. If you restart the mt-daapd server with iTunes open everything works great. The mt-daapd server will still be listed in the iTunes share after 30 minutes has passed (strange).

Last note:
I read about one guy who had to install a network bridge of some sorts. Could anyone give me some more insight into this? Could it work?

Thank you,
Trent.

Are you sure you turned off the firewall? that sure sounds like the server isn’t seeing inbound multicast packets.

You can test it, I guess… you can run tcpdump on the interface and open iTunes and see if you can see multicasts to udp port 5353 from 224.0.0.251.